summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-08-18 14:33:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-08-18 14:33:55 -0500
commit3427df169ef1ab3bdf4fa9cd469e2707a21078c3 (patch)
tree82a951cf79867232fccae16da8834945e2be4d3c /dev-libs/liblouis/liblouis-3.10.0.ebuild
parentdev-tex/pgf: Drop old (diff)
downloadgentoo-3427df169ef1ab3bdf4fa9cd469e2707a21078c3.tar.gz
gentoo-3427df169ef1ab3bdf4fa9cd469e2707a21078c3.tar.bz2
gentoo-3427df169ef1ab3bdf4fa9cd469e2707a21078c3.zip
dev-libs/liblouis: 3.10.0 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-libs/liblouis/liblouis-3.10.0.ebuild')
-rw-r--r--dev-libs/liblouis/liblouis-3.10.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/liblouis/liblouis-3.10.0.ebuild b/dev-libs/liblouis/liblouis-3.10.0.ebuild
new file mode 100644
index 000000000000..22df15db9502
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-3.10.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_REQ_USE='wide-unicode(+)'
+DISTUTILS_OPTIONAL=1
+inherit autotools distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://github.com/liblouis/liblouis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ucs4
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
+ HTML_DOCS=( doc/liblouis.html )
+ einstalldocs
+}