summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmateweather/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmateweather/files')
-rw-r--r--dev-libs/libmateweather/files/libmateweather-1.5.0-fix-automagic-python-support.patch12
-rw-r--r--dev-libs/libmateweather/files/libmateweather-1.6.1-fix-mkdirp.patch11
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/files/libmateweather-1.5.0-fix-automagic-python-support.patch b/dev-libs/libmateweather/files/libmateweather-1.5.0-fix-automagic-python-support.patch
new file mode 100644
index 000000000000..de5f44a2c0fd
--- /dev/null
+++ b/dev-libs/libmateweather/files/libmateweather-1.5.0-fix-automagic-python-support.patch
@@ -0,0 +1,12 @@
+diff -burN libmateweather-1.5.1.orig/configure.ac libmateweather-1.5.1/configure.ac
+--- libmateweather-1.5.1.orig/configure.ac 2013-02-04 15:53:55.420890494 +0100
++++ libmateweather-1.5.1/configure.ac 2013-02-04 15:55:19.618967277 +0100
+@@ -215,7 +215,7 @@
+ AC_ARG_ENABLE(python,
+ [AC_HELP_STRING([--enable-python],
+ [Build libmateweather python bindings])],
+- [enable_python=yes],
++ [enable_python=$enableval],
+ [enable_python=no])
+ if test "$enable_python" = "yes"; then
+ AM_PATH_PYTHON()
diff --git a/dev-libs/libmateweather/files/libmateweather-1.6.1-fix-mkdirp.patch b/dev-libs/libmateweather/files/libmateweather-1.6.1-fix-mkdirp.patch
new file mode 100644
index 000000000000..a76d6c76a192
--- /dev/null
+++ b/dev-libs/libmateweather/files/libmateweather-1.6.1-fix-mkdirp.patch
@@ -0,0 +1,11 @@
+diff -burN a/python/Makefile.am b/python/Makefile.am
+--- a/python/Makefile.am 2012-06-22 01:08:01.978411103 +0200
++++ b/python/Makefile.am 2012-06-22 01:11:02.007416691 +0200
+@@ -1,4 +1,7 @@
+ if BUILD_PYTHON
++
++MKDIR_P=@mkdir_p@
++
+ AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ $(PYTHON_INCLUDES) \