summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2018-01-27 18:07:16 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2018-02-11 15:59:38 +0100
commit4db80260cfed1e773bcbe14e253ae85b7d467361 (patch)
tree281a60b340d3ae3a209805e597bafe99bb045580 /dev-libs/libmateweather/libmateweather-1.18.2.ebuild
parentdev-libs/pcc-libs: remove unused patch (diff)
downloadgentoo-4db80260cfed1e773bcbe14e253ae85b7d467361.tar.gz
gentoo-4db80260cfed1e773bcbe14e253ae85b7d467361.tar.bz2
gentoo-4db80260cfed1e773bcbe14e253ae85b7d467361.zip
dev-libs/libmateweather: Bump to version 1.18.2
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libmateweather/libmateweather-1.18.2.ebuild')
-rw-r--r--dev-libs/libmateweather/libmateweather-1.18.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/libmateweather-1.18.2.ebuild b/dev-libs/libmateweather/libmateweather-1.18.2.ebuild
new file mode 100644
index 000000000000..409b39f404c9
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.18.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.34:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.0:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml
+}