summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 01:35:28 +0000
committerSam James <sam@gentoo.org>2021-01-07 01:35:28 +0000
commit752ff0abe92c4bd266106b169d8d7723e9a130d0 (patch)
treed1af277cf6ce9ab48d3cdfe32ac7edc34f4bcb71 /dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
parentdev-libs/libmaxminddb: sync live (diff)
downloadgentoo-752ff0abe92c4bd266106b169d8d7723e9a130d0.tar.gz
gentoo-752ff0abe92c4bd266106b169d8d7723e9a130d0.tar.bz2
gentoo-752ff0abe92c4bd266106b169d8d7723e9a130d0.zip
dev-libs/libmaxminddb: rename live to 9999
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmaxminddb/libmaxminddb-9999.ebuild')
-rw-r--r--dev-libs/libmaxminddb/libmaxminddb-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild b/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
new file mode 100644
index 000000000000..4979eebf44d8
--- /dev/null
+++ b/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs git-r3
+
+DESCRIPTION="C library for the MaxMind DB file format"
+HOMEPAGE="https://github.com/maxmind/libmaxminddb"
+EGIT_REPO_URI="https://github.com/maxmind/libmaxminddb.git"
+
+LICENSE="Apache-2.0"
+SLOT="0/0.0.7"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-perl/IPC-Run3 )
+"
+
+DOCS=( Changes.md )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+ tc-export AR CC
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}