summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmoe/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmoe/files')
-rw-r--r--dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch9
-rw-r--r--dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch23
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch b/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
new file mode 100644
index 000000000000..cf436c11577b
--- /dev/null
+++ b/dev-libs/libmoe/files/libmoe-1.5.8-gentoo.patch
@@ -0,0 +1,9 @@
+diff -Naur libmoe-1.5.8.orig/altmalloc.c libmoe-1.5.8/altmalloc.c
+--- libmoe-1.5.8.orig/altmalloc.c 2002-02-01 22:25:10.000000000 +0900
++++ libmoe-1.5.8/altmalloc.c 2008-11-19 08:44:34.000000000 +0900
+@@ -1,3 +1,5 @@
++#include <string.h>
++
+ #include "altmalloc.h"
+
+ alt_allocater_t alt_malloc = malloc;
diff --git a/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch b/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch
new file mode 100644
index 000000000000..2cdfa1a24c22
--- /dev/null
+++ b/dev-libs/libmoe/files/libmoe-1.5.8-makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 1bae380..605d674 100644
+--- a/Makefile
++++ b/Makefile
+@@ -72,8 +72,7 @@ AR=ar
+ all: ${INSTLIBA} mbconv mbconv.man
+
+ mbconv: mbconv.c ${ALL}
+- ${CC} ${CF} -o $@ $< -L. -lmoe
+-
++ ${CC} ${CF} ${LDFLAGS} -o $@ $< -L. -lmoe
+
+ ${DEST}.so: ${DEST}.so.${VER}.${RELEASE}
+ ln -sf $< $@
+@@ -116,7 +115,7 @@ ${BTRI_Cs}: %.c: %.mk_btri.c mk_btri
+ ./mk_btri <$< >$@-new && mv $@-new $@
+
+ mk_btri: btri.c btri.h altmalloc.o
+- ${CC} ${CF} -DMAIN -o $@ $< altmalloc.o
++ ${CC} ${CF} ${LDFLAGS} -DMAIN -o $@ $< altmalloc.o
+
+ mbconv.man: mbconv.pod
+ pod2man --section=${MANSECT} --center=' ' $< >$@