summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2020-05-31 14:58:30 -0700
committerSam James <sam@gentoo.org>2020-09-14 01:55:49 +0000
commit9a238bd0556fd612644eab4e0f329f60ab6f970b (patch)
tree73398473005a96313d088705c4ca55fdfb1228e2 /dev-libs/libmowgli/files
parentdev-libs/zziplib: add 'new' HOMEPAGE (diff)
downloadgentoo-9a238bd0556fd612644eab4e0f329f60ab6f970b.tar.gz
gentoo-9a238bd0556fd612644eab4e0f329f60ab6f970b.tar.bz2
gentoo-9a238bd0556fd612644eab4e0f329f60ab6f970b.zip
dev-libs/libmowgli: Fix 'ar' bug
Bug: https://bugs.gentoo.org/723028 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/17449 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmowgli/files')
-rw-r--r--dev-libs/libmowgli/files/libmowgli-2.1.3-use-host-tools-for-ar-and-ranlib.patch231
1 files changed, 231 insertions, 0 deletions
diff --git a/dev-libs/libmowgli/files/libmowgli-2.1.3-use-host-tools-for-ar-and-ranlib.patch b/dev-libs/libmowgli/files/libmowgli-2.1.3-use-host-tools-for-ar-and-ranlib.patch
new file mode 100644
index 000000000000..15e27c3bced0
--- /dev/null
+++ b/dev-libs/libmowgli/files/libmowgli-2.1.3-use-host-tools-for-ar-and-ranlib.patch
@@ -0,0 +1,231 @@
+diff --git a/configure b/configure
+index f7dce13..2b6ca08 100755
+--- a/configure
++++ b/configure
+@@ -3859,26 +3859,25 @@ $as_echo "#define HAVE_PS_STRINGS /**/" >>confdefs.h
+
+ fi
+
+-# Extract the first word of "ar", so it can be a program name with args.
+-set dummy ar; ac_word=$2
++if test -n "$ac_tool_prefix"; then
++ # Extract the first word of "${ac_tool_prefix}ar", so it can be a program name with args.
++set dummy ${ac_tool_prefix}ar; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_AR+:} false; then :
++if ${ac_cv_prog_AR+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+- case $AR in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_AR="$AR" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++ if test -n "$AR"; then
++ ac_cv_prog_AR="$AR" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+ for as_dir in $PATH
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_AR="$as_dir/$ac_word$ac_exec_ext"
++ ac_cv_prog_AR="${ac_tool_prefix}ar"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+@@ -3886,10 +3885,9 @@ done
+ done
+ IFS=$as_save_IFS
+
+- ;;
+-esac
+ fi
+-AR=$ac_cv_path_AR
++fi
++AR=$ac_cv_prog_AR
+ if test -n "$AR"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $AR" >&5
+ $as_echo "$AR" >&6; }
+@@ -3899,26 +3897,27 @@ $as_echo "no" >&6; }
+ fi
+
+
+-# Extract the first word of "ranlib", so it can be a program name with args.
+-set dummy ranlib; ac_word=$2
++fi
++if test -z "$ac_cv_prog_AR"; then
++ ac_ct_AR=$AR
++ # Extract the first word of "ar", so it can be a program name with args.
++set dummy ar; ac_word=$2
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+ $as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_RANLIB+:} false; then :
++if ${ac_cv_prog_ac_ct_AR+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+- case $RANLIB in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_RANLIB="$RANLIB" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++ if test -n "$ac_ct_AR"; then
++ ac_cv_prog_ac_ct_AR="$ac_ct_AR" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+ for as_dir in $PATH
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_RANLIB="$as_dir/$ac_word$ac_exec_ext"
++ ac_cv_prog_ac_ct_AR="ar"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+@@ -3926,10 +3925,61 @@ done
+ done
+ IFS=$as_save_IFS
+
+- ;;
++fi
++fi
++ac_ct_AR=$ac_cv_prog_ac_ct_AR
++if test -n "$ac_ct_AR"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_AR" >&5
++$as_echo "$ac_ct_AR" >&6; }
++else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++fi
++
++ if test "x$ac_ct_AR" = x; then
++ AR=""
++ else
++ case $cross_compiling:$ac_tool_warned in
++yes:)
++{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
++$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
++ac_tool_warned=yes ;;
+ esac
++ AR=$ac_ct_AR
++ fi
++else
++ AR="$ac_cv_prog_AR"
++fi
++
++if test -n "$ac_tool_prefix"; then
++ # Extract the first word of "${ac_tool_prefix}ranlib", so it can be a program name with args.
++set dummy ${ac_tool_prefix}ranlib; ac_word=$2
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
++$as_echo_n "checking for $ac_word... " >&6; }
++if ${ac_cv_prog_RANLIB+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ if test -n "$RANLIB"; then
++ ac_cv_prog_RANLIB="$RANLIB" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_prog_RANLIB="${ac_tool_prefix}ranlib"
++ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++ done
++IFS=$as_save_IFS
++
++fi
+ fi
+-RANLIB=$ac_cv_path_RANLIB
++RANLIB=$ac_cv_prog_RANLIB
+ if test -n "$RANLIB"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RANLIB" >&5
+ $as_echo "$RANLIB" >&6; }
+@@ -3939,6 +3989,60 @@ $as_echo "no" >&6; }
+ fi
+
+
++fi
++if test -z "$ac_cv_prog_RANLIB"; then
++ ac_ct_RANLIB=$RANLIB
++ # Extract the first word of "ranlib", so it can be a program name with args.
++set dummy ranlib; ac_word=$2
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
++$as_echo_n "checking for $ac_word... " >&6; }
++if ${ac_cv_prog_ac_ct_RANLIB+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ if test -n "$ac_ct_RANLIB"; then
++ ac_cv_prog_ac_ct_RANLIB="$ac_ct_RANLIB" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_prog_ac_ct_RANLIB="ranlib"
++ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++ done
++IFS=$as_save_IFS
++
++fi
++fi
++ac_ct_RANLIB=$ac_cv_prog_ac_ct_RANLIB
++if test -n "$ac_ct_RANLIB"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_RANLIB" >&5
++$as_echo "$ac_ct_RANLIB" >&6; }
++else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++fi
++
++ if test "x$ac_ct_RANLIB" = x; then
++ RANLIB=""
++ else
++ case $cross_compiling:$ac_tool_warned in
++yes:)
++{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
++$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
++ac_tool_warned=yes ;;
++esac
++ RANLIB=$ac_ct_RANLIB
++ fi
++else
++ RANLIB="$ac_cv_prog_RANLIB"
++fi
++
+
+ LIBMOWGLI_MODULES="core base container dns eventloop ext linebuf module object platform thread vio"
+
+diff --git a/configure.ac b/configure.ac
+index dfebb14..b3bd072 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -36,8 +36,8 @@ if test "$pgac_cv_var_PS_STRINGS" = yes ; then
+ AC_DEFINE([HAVE_PS_STRINGS], [], [Define to 1 if the PS_STRINGS struct exists on your platform (likely no).])
+ fi
+
+-AC_PATH_PROG(AR, ar)
+-AC_PATH_PROG(RANLIB, ranlib)
++AC_CHECK_TOOL(AR, ar)
++AC_CHECK_TOOL(RANLIB, ranlib)
+
+ LIBMOWGLI_MODULES="core base container dns eventloop ext linebuf module object platform thread vio"
+ AC_SUBST(LIBMOWGLI_MODULES)