summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2017-08-24 21:59:13 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2017-08-24 21:59:27 +0200
commitf6f41d931a86fc8b6aad0078b3a8a20e7ebff8bf (patch)
tree311040990327c527ddd5e0f6cae7dcfbc33d0a95 /dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild
parentnet-misc/openvswitch: switch to split twisted bug 628028 (diff)
downloadgentoo-f6f41d931a86fc8b6aad0078b3a8a20e7ebff8bf.tar.gz
gentoo-f6f41d931a86fc8b6aad0078b3a8a20e7ebff8bf.tar.bz2
gentoo-f6f41d931a86fc8b6aad0078b3a8a20e7ebff8bf.zip
dev-libs/libmspack: CVE-2017-6419, bug 628684.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild')
-rw-r--r--dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild b/dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild
new file mode 100644
index 000000000000..f8c7bd3ce1d1
--- /dev/null
+++ b/dev-libs/libmspack/libmspack-0.5_alpha-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+MY_PV="${PV/_alpha/alpha}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A library for Microsoft compression formats"
+HOMEPAGE="https://www.cabextract.org.uk/libmspack/"
+SRC_URI="https://www.cabextract.org.uk/libmspack/libmspack-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-CVE-2017-6419.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ default
+ cd "${S}"/test && "${BUILD_DIR}"/test/cabd_test || die
+ fi
+}
+
+multilib_src_install_all() {
+ DOCS=(AUTHORS ChangeLog NEWS README TODO)
+ prune_libtool_files --all
+ use doc && HTML_DOCS=(doc/*)
+ default_src_install
+ if use doc; then
+ rm "${ED}"/usr/share/doc/"${PF}"/html/{Makefile*,Doxyfile*} || die
+ fi
+}