summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 23:21:52 +0000
committerSam James <sam@gentoo.org>2021-01-12 23:34:12 +0000
commit4947b1f61d9cb2db76a6f555f58ce9cb50e3fd72 (patch)
tree51771217b5e339d62d15e410ac8609dab8b9f0ab /dev-libs/libnl/libnl-99999999.ebuild
parentsys-kernel/gentoo-sources: Remove old, EOL'd linux version (diff)
downloadgentoo-4947b1f61d9cb2db76a6f555f58ce9cb50e3fd72.tar.gz
gentoo-4947b1f61d9cb2db76a6f555f58ce9cb50e3fd72.tar.bz2
gentoo-4947b1f61d9cb2db76a6f555f58ce9cb50e3fd72.zip
dev-libs/libnl: add Python 3.9
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libnl/libnl-99999999.ebuild')
-rw-r--r--dev-libs/libnl/libnl-99999999.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/dev-libs/libnl/libnl-99999999.ebuild b/dev-libs/libnl/libnl-99999999.ebuild
index cf078de887a5..b90a505c18e7 100644
--- a/dev-libs/libnl/libnl-99999999.ebuild
+++ b/dev-libs/libnl/libnl-99999999.ebuild
@@ -1,38 +1,33 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1 git-r3 multilib-minimal
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
EGIT_REPO_URI="https://github.com/thom311/libnl"
+
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
KEYWORDS=""
IUSE="+debug static-libs python +threads utils"
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="
- ${RDEPEND}
-"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
BDEPEND="
${RDEPEND}
sys-devel/bison
sys-devel/flex
python? ( dev-lang/swig )
"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-DOCS=(
- ChangeLog
-)
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( ChangeLog )
+
MULTILIB_WRAPPED_HEADERS=(
# we do not install CLI stuff for non-native
/usr/include/libnl3/netlink/cli/addr.h
@@ -48,6 +43,7 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libnl3/netlink/cli/tc.h
/usr/include/libnl3/netlink/cli/utils.h
)
+
PATCHES=(
"${FILESDIR}"/${PN}-99999999-2to3.patch
)
@@ -107,5 +103,5 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}