summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-18 22:17:38 +0000
committerSam James <sam@gentoo.org>2022-07-18 22:22:44 +0000
commit62c57ba88bff4041d3c8a476baa2c074fdff1e3d (patch)
treeabb0518874887d0bf74fc43dc4b6c034214ffe9e /dev-libs/libnl
parentdev-libs/libnl: add 3.7.0 (diff)
downloadgentoo-62c57ba88bff4041d3c8a476baa2c074fdff1e3d.tar.gz
gentoo-62c57ba88bff4041d3c8a476baa2c074fdff1e3d.tar.bz2
gentoo-62c57ba88bff4041d3c8a476baa2c074fdff1e3d.zip
dev-libs/libnl: rename live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/libnl-3.7.0.ebuild12
-rw-r--r--dev-libs/libnl/libnl-9999.ebuild (renamed from dev-libs/libnl/libnl-99999999.ebuild)47
2 files changed, 34 insertions, 25 deletions
diff --git a/dev-libs/libnl/libnl-3.7.0.ebuild b/dev-libs/libnl/libnl-3.7.0.ebuild
index ee24246ef92f..6b420eb95d66 100644
--- a/dev-libs/libnl/libnl-3.7.0.ebuild
+++ b/dev-libs/libnl/libnl-3.7.0.ebuild
@@ -14,12 +14,18 @@ LIBNL_DIR=${LIBNL_DIR//./_}
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
-SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
-S="${WORKDIR}/${LIBNL_P}"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/thom311/libnl"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ S="${WORKDIR}/${LIBNL_P}"
+fi
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+debug python test utils"
RESTRICT="!test? ( test )"
diff --git a/dev-libs/libnl/libnl-99999999.ebuild b/dev-libs/libnl/libnl-9999.ebuild
index 0cfee098abde..6b420eb95d66 100644
--- a/dev-libs/libnl/libnl-99999999.ebuild
+++ b/dev-libs/libnl/libnl-9999.ebuild
@@ -1,35 +1,43 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 git-r3 multilib-minimal
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools distutils-r1 multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="https://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
-EGIT_REPO_URI="https://github.com/thom311/libnl"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/thom311/libnl"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ S="${WORKDIR}/${LIBNL_P}"
+fi
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
-KEYWORDS=""
IUSE="+debug python test utils"
RESTRICT="!test? ( test )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
-BDEPEND="
- ${RDEPEND}
+BDEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex
python? ( dev-lang/swig )
- test? ( dev-libs/check )
-"
+ test? ( dev-libs/check )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DOCS=( ChangeLog )
-
MULTILIB_WRAPPED_HEADERS=(
# we do not install CLI stuff for non-native
/usr/include/libnl3/netlink/cli/addr.h
@@ -57,15 +65,10 @@ src_prepare() {
distutils-r1_src_prepare
popd > /dev/null || die
fi
-
- # out-of-source build broken
- # https://github.com/thom311/libnl/pull/58
- multilib_copy_sources
}
multilib_src_configure() {
- econf \
- --disable-static \
+ ECONF_SOURCE="${S}" econf \
$(multilib_native_use_enable utils cli) \
$(use_enable debug)
}
@@ -73,7 +76,7 @@ multilib_src_configure() {
multilib_src_compile() {
default
- if multilib_is_native_abi && use python; then
+ if multilib_is_native_abi && use python ; then
pushd python > /dev/null || die
distutils-r1_src_compile
popd > /dev/null || die
@@ -83,7 +86,7 @@ multilib_src_compile() {
multilib_src_install() {
default
- if multilib_is_native_abi && use python; then
+ if multilib_is_native_abi && use python ; then
# Unset DOCS= since distutils-r1.eclass interferes
local DOCS=()
@@ -91,14 +94,14 @@ multilib_src_install() {
distutils-r1_src_install
- # For no obvious reason this is not done automatically
- python_foreach_impl python_optimize
-
popd > /dev/null || die
fi
}
multilib_src_install_all() {
+ DOCS=( ChangeLog )
+
einstalldocs
+
find "${ED}" -name '*.la' -delete || die
}