summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-12-31 00:58:27 +0100
committerJeroen Roovers <jer@gentoo.org>2016-12-31 00:58:27 +0100
commit6ec855f09fd7810b8c0d32dcdc7082d5d1b5c7f7 (patch)
treeb567a60b1ec505a20a5e267f9061f20289d51fd4 /dev-libs/libnl
parentnet-dns/libidn2: Do not regenerate idn2_cmd.c (bug #604146). (diff)
downloadgentoo-6ec855f09fd7810b8c0d32dcdc7082d5d1b5c7f7.tar.gz
gentoo-6ec855f09fd7810b8c0d32dcdc7082d5d1b5c7f7.tar.bz2
gentoo-6ec855f09fd7810b8c0d32dcdc7082d5d1b5c7f7.zip
dev-libs/libnl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/Manifest1
-rw-r--r--dev-libs/libnl/libnl-3.2.29.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index 7f7b43003be6..d8d6b1f0ae0b 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -2,3 +2,4 @@ DIST libnl-1.1.4.tar.gz 1174974 SHA256 4f80c21fe5bbcdde6e72b59b4f98306063a41421f
DIST libnl-3.2.27.tar.gz 905330 SHA256 4bbbf92b3c78a90f423cf96260bf419a28b75db8cced47051217a56795f58ec6 SHA512 f66d1c42eef75f6a1008abd6850f00abb0290d49bb685b4df43464c4dbf57d68fd4551f2a77bb2f375fd0a342b73cfd54d17c791f01ea43ce02683c8703e3a33 WHIRLPOOL 0bf32ca28b1f858caf99cb633ae4c3b863e53f8cb4b3b1703b454117e2eea2563d34b08c4ac920afb63e45c4717ba7628730a428df76f56818fe10cf336c4185
DIST libnl-3.2.28.tar.gz 941954 SHA256 cd608992c656e8f6e3ab6c1391b162a5a51c49336b9219f7f390e61fc5437c41 SHA512 b5f145ecafb2625ed1c42594afd6063f112a601077de5c35884b3c3bc8c562b29b52a006ccebd795c127fe69692a82def425c8605afed7e6d441582943e803d9 WHIRLPOOL ff49346ddc31105a300ebffc0e4d4956ac85ade5e92e884c62e696d7d4234d40e63cf4839e6b6fd2d98d2122662d36d3f41666391686a83c8bf966e53e22ed25
DIST libnl-3.2.29-rc1.tar.gz 963474 SHA256 97f75893b1268471ecf04acb23fe15a70e75827239863900254eb17aad733504 SHA512 8b00896452feba58748aaba5e84dc0b79f336fb1aaf3f309f619d5567c30c81dc6a00cb81003c30f3633bdaffaf39371a9833cca5fa3402f754c5509a4d4b52f WHIRLPOOL c8d1a25bdf665f67d219b515e7d2be8fff2e114575bf911f2a7f4295351d9095193d65b6cc79a7898d365d0dc1ec13098d9ee9476ae8b1c2e0b841f18541f6e0
+DIST libnl-3.2.29.tar.gz 963681 SHA256 0beb593dc6abfffa18a5c787b27884979c1b7e7f1fd468c801e3cc938a685922 SHA512 45e22b02368c479e01db7160345a0d3c73abf345e7b49bf350811243a17f307f5c6c3df639ec1e0c456707578aca8d69aad8afa697ac21449f521a3e39712670 WHIRLPOOL 1273dcaee79ecfdca947110c5e7ff70947703b1b0fda43fdb7c74edd78c6938f675e9a586aaff8feefce56a1f3137cbc50d3626ac336e6afa2ca8cbd8627e6eb
diff --git a/dev-libs/libnl/libnl-3.2.29.ebuild b/dev-libs/libnl/libnl-3.2.29.ebuild
new file mode 100644
index 000000000000..5c5c56579d80
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.29.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1 eutils libtool multilib multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+SRC_URI="
+ https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz
+"
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="static-libs python utils"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ sys-devel/bison
+ sys-devel/flex
+"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+DOCS=(
+ ChangeLog
+)
+
+S=${WORKDIR}/${LIBNL_P}
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+ "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
+ "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+
+ # out-of-source build broken
+ # https://github.com/thom311/libnl/pull/58
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils cli)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+ cd python || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}