summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2021-10-31 15:38:39 +1300
committerSam James <sam@gentoo.org>2021-11-14 05:24:33 +0000
commit4a153d2644a4108e8f3c8bcfe9b9413cceea7033 (patch)
tree66c7265484644e7050cb633564c42a1fdfbb1535 /dev-libs/liborcus/liborcus-9999.ebuild
parentdev-libs/liborcus: fix build failure with USE=-tools (diff)
downloadgentoo-4a153d2644a4108e8f3c8bcfe9b9413cceea7033.tar.gz
gentoo-4a153d2644a4108e8f3c8bcfe9b9413cceea7033.tar.bz2
gentoo-4a153d2644a4108e8f3c8bcfe9b9413cceea7033.zip
dev-libs/liborcus: add 0.17.0
Signed-off-by: James Beddek <telans@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/liborcus/liborcus-9999.ebuild')
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 85508fc2f047..b923d9595f82 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit python-single-r1
+
+inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
@@ -12,7 +13,7 @@ HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
MDDS_SLOT="1/9999"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
+ inherit git-r3
else
MDDS_SLOT="1/1.5"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
@@ -20,7 +21,7 @@ else
fi
LICENSE="MIT"
-SLOT="0/0.16" # based on SONAME of liborcus.so
+SLOT="0/0.17" # based on SONAME of liborcus.so
IUSE="python +spreadsheet-model tools"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -41,7 +42,7 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {