summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-09 00:57:57 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-09 00:58:14 +0100
commitb4492759eb4e4d96bcaa145d21a1c2f06dc27c4b (patch)
tree56b5bc32d0db7303c7349914e01dd31cc66f751d /dev-libs/liborcus/liborcus-9999.ebuild
parentdev-util/mdds: Fix subslot in live ebuild (diff)
downloadgentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.tar.gz
gentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.tar.bz2
gentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.zip
dev-libs/liborcus: Untested bump, work in progress
Closes: https://bugs.gentoo.org/830457 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-libs/liborcus/liborcus-9999.ebuild')
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index b923d9595f82..16b12b9e36fa 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit autotools python-single-r1
@@ -11,20 +11,22 @@ DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/9999"
+ MDDS_SLOT="1/2.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
inherit git-r3
else
- MDDS_SLOT="1/1.5"
+ MDDS_SLOT="1/2.0"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ # Unkeyworded while libreoffice has no release making use of this slot
+ # KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
SLOT="0/0.17" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model tools"
+IUSE="python +spreadsheet-model test tools"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -41,6 +43,9 @@ pkg_setup() {
}
src_prepare() {
+ # bug 713586
+ use test && eapply "${FILESDIR}/${P}-test-fix.patch"
+
default
eautoreconf
}
@@ -59,5 +64,4 @@ src_configure() {
src_install() {
default
find "${D}" -name '*.la' -type f -delete || die
- use python && python_optimize
}