summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 11:20:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 11:27:09 +0100
commit632310480c2bd41af986d9c6580969fe9d29cab3 (patch)
treef52b1b3e5fab3621a4aaf0fc732d2819283fd594 /dev-libs/liborcus
parentdev-libs/libixion: python3_11 (diff)
downloadgentoo-632310480c2bd41af986d9c6580969fe9d29cab3.tar.gz
gentoo-632310480c2bd41af986d9c6580969fe9d29cab3.tar.bz2
gentoo-632310480c2bd41af986d9c6580969fe9d29cab3.zip
dev-libs/liborcus: python3_11
Tests pass. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/files/liborcus-0.17.2-python-optional.patch26
-rw-r--r--dev-libs/liborcus/liborcus-0.17.2-r1.ebuild70
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-libs/liborcus/files/liborcus-0.17.2-python-optional.patch b/dev-libs/liborcus/files/liborcus-0.17.2-python-optional.patch
new file mode 100644
index 000000000000..9473958c196a
--- /dev/null
+++ b/dev-libs/liborcus/files/liborcus-0.17.2-python-optional.patch
@@ -0,0 +1,26 @@
+From 14d15bf331b5cc3ca2c1cdb8097dfe918173cba1 Mon Sep 17 00:00:00 2001
+From: matoro <11910244-matoro3@users.noreply.gitlab.com>
+Date: Wed, 24 Aug 2022 13:42:27 -0400
+Subject: [PATCH] Only recurse into src/python when BUILD_PYTHON is set
+
+---
+ src/Makefile.am | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index d586299c..7e44aed8 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,8 @@
+-SUBDIRS = include test parser mso liborcus spreadsheet python
++SUBDIRS = include test parser mso liborcus spreadsheet
++
++if BUILD_PYTHON
++SUBDIRS += python
++endif
+
+ AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+--
+GitLab
+
diff --git a/dev-libs/liborcus/liborcus-0.17.2-r1.ebuild b/dev-libs/liborcus/liborcus-0.17.2-r1.ebuild
new file mode 100644
index 000000000000..bb555485c7bb
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.17.2-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/2.0"
+ EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+ inherit git-r3
+else
+ MDDS_SLOT="1/2.0"
+ SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.17" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model test tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=[zlib(+)]
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( dev-libs/libixion:${SLOT} )
+"
+DEPEND="${RDEPEND}
+ dev-util/mdds:${MDDS_SLOT}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang.patch
+ "${FILESDIR}"/${P}-gcc-13.patch
+ "${FILESDIR}"/${P}-python-optional.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # bug 713586
+ use test && eapply "${FILESDIR}/${PN}-0.17.0-test-fix.patch"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable python)
+ $(use_enable spreadsheet-model)
+ $(use_with tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}