summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-24 21:17:54 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-10-02 00:08:34 +0200
commitddec7ca33a41869d9ae88970201d10a2ad4b4e15 (patch)
treec0aedb57fc9c68c903abfd9f04dd6cc0852dcceb /dev-libs/liborcus
parentdev-libs/libixion: Version bump to 0.12.1 (diff)
downloadgentoo-ddec7ca33a41869d9ae88970201d10a2ad4b4e15.tar.gz
gentoo-ddec7ca33a41869d9ae88970201d10a2ad4b4e15.tar.bz2
gentoo-ddec7ca33a41869d9ae88970201d10a2ad4b4e15.zip
dev-libs/liborcus: Version bump to 0.12.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.12.1.ebuild59
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild13
-rw-r--r--dev-libs/liborcus/metadata.xml3
4 files changed, 69 insertions, 7 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 1113868ac31c..63d0e8800bb7 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,3 +1,4 @@
DIST liborcus-0.11.2.tar.xz 1627540 SHA256 6911dc65a4d8276e42d32764e9ebee920b325cf59cfa7070fc72744d43b259ad SHA512 2100ae273e5c963123a5212d51793fe11a7fae9268a21629007034b92c3bf283522313a033de78a6a732b367c42a6eb4f6d3288d33124827fa0788f75abdd741 WHIRLPOOL caf9d7d977501620ad7eade470e7988159d93521c48d3b930bf212349d9ee03db971d68943dc9b0690429f3677d8d87b9a7f35e697b8307c9e2338043e4bb0f4
+DIST liborcus-0.12.1.tar.xz 1673880 SHA256 d1b936c66944d23e1b2582d0e7129e44670052510d03f19fef644e9814ae2b9c SHA512 294b24ad7fccae77070edd9d8e6e1a370f609ec8af9a2c58567431e641fc0f3f27c4cd4b6ac1825a8179a22a1d1a81d84827859eb631d2625194f9e59ca1a8c3 WHIRLPOOL f62dd79ccb94e2b054cec12147d6c10505a3d64309566703469eabf6da1aa71530c74901dc2ee66d21199999fc0661fac391d6abd5e7eefab186f9bbca729ea4
DIST liborcus-0.7.1.tar.xz 1472804 SHA256 04846b64262210a0d4e18d72779c901633e45dc9cca2108235b38d4715266a43 SHA512 30461311b084f3c91ef8cc504ca7adfd212f95d49c0a320958ca203606901ddf84e37d5c95073437bad21af4c6ce71fa606dd7cdb7cc7bd58b2699d8863a318c WHIRLPOOL af6f4ff639851b94298f847437c25962412f37617f82c143b1bf71aa4f27b26003ffb2dad61fdbe9718f9b42a0f11c1dda71825da8b2ee8bf9e9fd727f309134
DIST liborcus-0.9.2.tar.xz 1558072 SHA256 dd49f9f1b8ff8a648434dd5c8b4fe1081d1118d61d0a71d4effee8f32553199c SHA512 1dd847012cf78df962c28408e0b56412a89e1d978d532a17fa92352f6788bbc1a0fe806c2d886ff148a8ee2db54620ce039b1809f347a976dca0078f248fd8ea WHIRLPOOL fe74951704b4cfbdfeeb894be459c4f7046fc23f813c50e43816943d064cbfc4a4f7feebf6a6737cf94d50826ac23796031b7626b89264ee21f42356ffbb44e8
diff --git a/dev-libs/liborcus/liborcus-0.12.1.ebuild b/dev-libs/liborcus/liborcus-0.12.1.ebuild
new file mode 100644
index 000000000000..5e361d4d82e5
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.12.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit eutils python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.12" # based on SONAME of liborcus.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+# KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="python +spreadsheet-model static-libs tools"
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( >=dev-libs/libixion-0.12.1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.2:1
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable python) \
+ $(use_enable spreadsheet-model) \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 524969bc30ea..4c941bf77357 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
-PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_COMPAT=( python3_{4,5} )
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
inherit eutils python-single-r1 ${GITECLASS}
@@ -17,19 +17,19 @@ HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/orcus/src/${P}.tar.xz"
LICENSE="MIT"
-SLOT="0/0.11" # based on SONAME of liborcus.so
+SLOT="0/0.12" # based on SONAME of liborcus.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="python +spreadsheet-model static-libs tools"
RDEPEND="
- >=dev-libs/boost-1.51.0:=
+ dev-libs/boost:=
sys-libs/zlib:=
python? ( ${PYTHON_DEPS} )
- spreadsheet-model? ( >=dev-libs/libixion-0.11.1:= )
+ spreadsheet-model? ( >=dev-libs/libixion-0.12.1:= )
"
DEPEND="${RDEPEND}
- >=dev-util/mdds-1.2.0:1
+ >=dev-util/mdds-1.2.2:1
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -39,7 +39,7 @@ pkg_setup() {
}
src_prepare() {
- eapply_user
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}
@@ -54,6 +54,5 @@ src_configure() {
src_install() {
default
-
prune_libtool_files --all
}
diff --git a/dev-libs/liborcus/metadata.xml b/dev-libs/liborcus/metadata.xml
index 76fa89e1b408..2183abc3f7bf 100644
--- a/dev-libs/liborcus/metadata.xml
+++ b/dev-libs/liborcus/metadata.xml
@@ -5,6 +5,9 @@
<email>office@gentoo.org</email>
<name>Gentoo Office project</name>
</maintainer>
+ <slots>
+ <subslots>liborcus soname version</subslots>
+ </slots>
<use>
<flag name="spreadsheet-model">Enable the spreadsheet model implementation</flag>
<flag name="tools">Build miscellaneous tools</flag>