summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-03 20:30:08 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:38 +0200
commitdae4c8359e0208fdd13cc3265cc859230251045f (patch)
treed888ef0fb7858516f3fc69a7a329d705301914ba /dev-libs/libp11/libp11-0.4.4.ebuild
parentdev-libs/xmlsec: version bump (diff)
downloadgentoo-dae4c8359e0208fdd13cc3265cc859230251045f.tar.gz
gentoo-dae4c8359e0208fdd13cc3265cc859230251045f.tar.bz2
gentoo-dae4c8359e0208fdd13cc3265cc859230251045f.zip
dev-libs/libp11: version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-libs/libp11/libp11-0.4.4.ebuild')
-rw-r--r--dev-libs/libp11/libp11-0.4.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.4.4.ebuild b/dev-libs/libp11/libp11-0.4.4.ebuild
new file mode 100644
index 000000000000..95e229fa1d00
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl bindist doc static-libs"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}