summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-03 04:47:32 +0000
committerSam James <sam@gentoo.org>2021-12-03 04:50:25 +0000
commit43c40c442031ddec003f197980a5725a2c685b1f (patch)
tree9df3d2ce0780fb790228c44002b878e9173875b8 /dev-libs/libp11
parentdev-libs/botan: adapt for OpenSSL bindist changes (diff)
downloadgentoo-43c40c442031ddec003f197980a5725a2c685b1f.tar.gz
gentoo-43c40c442031ddec003f197980a5725a2c685b1f.tar.bz2
gentoo-43c40c442031ddec003f197980a5725a2c685b1f.zip
dev-libs/libp11: adapt for OpenSSL bindist changes
OpenSSL no longer has a bindist flag. Bug: https://bugs.gentoo.org/762850 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libp11')
-rw-r--r--dev-libs/libp11/libp11-0.4.11-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.4.11-r2.ebuild b/dev-libs/libp11/libp11-0.4.11-r2.ebuild
new file mode 100644
index 000000000000..d95932eb7fc6
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.11-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}