summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Corvinus <voron1@gmail.com>2022-12-12 18:48:24 +0400
committerAmy Liffey <amynka@gentoo.org>2022-12-12 19:39:45 +0100
commit25d2dec890c80bf01b9211ce38bc28b3b2e7a7a6 (patch)
tree3806d03db9e2307ea5366db6e944bbd6dffed7a5 /dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
parentdev-php/pecl-event: Version bump for 3.0.8 (diff)
downloadgentoo-25d2dec890c80bf01b9211ce38bc28b3b2e7a7a6.tar.gz
gentoo-25d2dec890c80bf01b9211ce38bc28b3b2e7a7a6.tar.bz2
gentoo-25d2dec890c80bf01b9211ce38bc28b3b2e7a7a6.zip
dev-libs/libqt5pas: new package, add 1.2.9
Closes: https://bugs.gentoo.org/645228 Signed-off-by: Amy Liffey <amynka@gentoo.org> Signed-off-by: Michael Corvinus <voron1@gmail.com>
Diffstat (limited to 'dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild')
-rw-r--r--dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild b/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
new file mode 100644
index 000000000000..cd2b7135bb7c
--- /dev/null
+++ b/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_P="lazarus-2.2.4-0"
+
+DESCRIPTION="Free Pascal Qt5 bindings library updated by lazarus IDE."
+HOMEPAGE="https://gitlab.com/freepascal.org/lazarus/lazarus"
+SRC_URI="mirror://sourceforge/lazarus/${MY_P}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0/2.2"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+"
+
+S="${WORKDIR}/lazarus/lcl/interfaces/qt5/cbindings"
+
+src_configure() {
+ eqmake5 "QT += x11extras" Qt5Pas.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}