summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 17:45:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:33 +0300
commita3588441916f7a32d8e0d983def4156ecdc2f968 (patch)
tree0e8f55da9090fa6a0dfd8d12922c266de7aa6c91 /dev-libs/libqtxdg
parentdev-util/lxqt-build-tools: add version 0.9.0 (diff)
downloadgentoo-a3588441916f7a32d8e0d983def4156ecdc2f968.tar.gz
gentoo-a3588441916f7a32d8e0d983def4156ecdc2f968.tar.bz2
gentoo-a3588441916f7a32d8e0d983def4156ecdc2f968.zip
dev-libs/libqtxdg: add version 3.7.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libqtxdg')
-rw-r--r--dev-libs/libqtxdg/Manifest1
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.7.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/Manifest b/dev-libs/libqtxdg/Manifest
index 31f520e5311c..a7500221a5cc 100644
--- a/dev-libs/libqtxdg/Manifest
+++ b/dev-libs/libqtxdg/Manifest
@@ -1 +1,2 @@
DIST libqtxdg-3.6.0.tar.xz 76028 BLAKE2B 138f0f8bf9889c7f6aa0d4016c52d4c7745a9f3b34b53babba5d0be457485157d66884395488d4e978ba953332696b977bb60c1d04b6b0a53086ab7f3b0b4492 SHA512 8574bb6834c0a44c983e906c3d84fb5cfd6e2f40ec2ac70f4998ec5fe213aeb0d4439ff294f56c1988cb9d1b311c4e074906ba66b21d24190a911d0e643d1a16
+DIST libqtxdg-3.7.1.tar.xz 74832 BLAKE2B 92b0f47412e04fa3100f1045a0ceb69ee7787634ab02883958156b96e756aecae1e916fa9963ef072e1d78f337102b2bfb7a42a1dcd9481fd158dde73e57fcef SHA512 764fb953c5c5564a8f5e189f3fa867b82e1da215e0734d2fb995bb29ba163936a38cf68c6c812ff3c183b7ab4fce59d1189c68885b65f103accb5446e71682e7
diff --git a/dev-libs/libqtxdg/libqtxdg-3.7.1.ebuild b/dev-libs/libqtxdg/libqtxdg-3.7.1.ebuild
new file mode 100644
index 000000000000..ef6c277b7552
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake optfeature virtualx
+
+DESCRIPTION="Qt Implementation of XDG Standards"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-util/lxqt-build-tools-0.9.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake_src_test
+}
+
+pkg_postinst() {
+ ! has_version lxqt-base/lxqt-meta && optfeature "features that require a terminal emulator" x11-terms/xterm
+}