summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-21 01:32:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-21 03:17:15 +0100
commit3fd59c1a54d8e729a295b5c02b294da9f4d005f5 (patch)
tree25bab0ad714422dfb6f6261b3bbc4a27c7e0972e /dev-libs/librelp
parentx11-misc/wdm: drop project desktop-misc (diff)
downloadgentoo-3fd59c1a54d8e729a295b5c02b294da9f4d005f5.tar.gz
gentoo-3fd59c1a54d8e729a295b5c02b294da9f4d005f5.tar.bz2
gentoo-3fd59c1a54d8e729a295b5c02b294da9f4d005f5.zip
dev-libs/librelp: bump to v1.10.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/librelp')
-rw-r--r--dev-libs/librelp/Manifest1
-rw-r--r--dev-libs/librelp/librelp-1.10.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/librelp/Manifest b/dev-libs/librelp/Manifest
index 09cb240276de..2d37b2b521b4 100644
--- a/dev-libs/librelp/Manifest
+++ b/dev-libs/librelp/Manifest
@@ -1,3 +1,4 @@
+DIST librelp-1.10.0.tar.gz 543414 BLAKE2B 3c7bace3c7892755c943dc4fc9bee7962e6891f5200ac184555da5f552d19d65f5604c745653d06a87210152af9b57f7234636e59257dd29dc83b5dc566c9680 SHA512 a38840231902bec034edb497166deded7577c989e4f735e406c8488384972925de1ca6132b3080472f7919d2439559c8774c02a49c356e90ad791dfbba2a4865
DIST librelp-1.7.0.tar.gz 532967 BLAKE2B 19e3eaa05aa7a53b4701eaf96b3be6d8467c7f5c0de0bc1ba81fcb6d6ed6529146140a32b05fcdb47330be2b573a9d84779ea519dd9cacf50d3b7710d523b808 SHA512 e9d71f27d5c50b043254a3f1b0643e7172e5678b6a5a7dddb9d4a9e3afa3ed0adf818a4e868960c1607da5f63430f163f9e76c882ed5460149cb1cceff42b4bd
DIST librelp-1.8.0.tar.gz 539467 BLAKE2B 3d1d396059955d2b83a21a42838b56c6a18cde296e6b7c4beb79ba9a8d222d7e5d738419b87b24ed05da553cb16fd827e8820c4c81c50d5a3770ad745efe3ef5 SHA512 aa3e02010cdd4587ff28987f00291708e752b2e2f5f37f5a5239bda6992f55cf428cf1b6e06847062be31844cfdda6b654bcbb9024dff943d140b405ec93c0f4
DIST librelp-1.9.0.tar.gz 540477 BLAKE2B b42e35e2f3e310cc4a978a6d2f0a127317414d93d87bede5e1bbe69e3031482b4d895bba2256668d383911e2ef55cc3086a44d8bebb15ea56c6ebd28e64e545b SHA512 3cb8cf2707cff662bd0b9100c737458b6b96820db7e362094c77cdb50455fcb944d7760921e0b758a3a6cd15d685f488a976fe909de034c289635c660caae723
diff --git a/dev-libs/librelp/librelp-1.10.0.ebuild b/dev-libs/librelp/librelp-1.10.0.ebuild
new file mode 100644
index 000000000000..c93e6e68ef55
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.10.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="https://www.rsyslog.com/librelp/"
+SRC_URI="https://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ doc? ( FDL-1.3 )"
+
+# subslot = soname version
+SLOT="0/0.5.1"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl +gnutls libressl openssl static-libs test"
+REQUIRED_USE="ssl? ( ^^ ( gnutls openssl ) )"
+
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ virtual/pkgconfig"
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/ -g"/"/g' \
+ configure.ac || die "sed failed"
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-valgrind
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable openssl tls-openssl)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ local DOCS=( ChangeLog )
+ use doc && local HTML_DOCS=( doc/relp.html )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}