summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-02-23 16:38:50 +0100
committerPacho Ramos <pacho@gentoo.org>2019-02-23 16:59:19 +0100
commit89d02633a473d31ec655dc0b45ec72948687194e (patch)
treec9c331e3c3563d68562188403a7c81e1d2e51b58 /dev-libs/libreport/libreport-2.10.0.ebuild
parentmedia-libs/libchamplain: Version bump to 0.12.18 (diff)
downloadgentoo-89d02633a473d31ec655dc0b45ec72948687194e.tar.gz
gentoo-89d02633a473d31ec655dc0b45ec72948687194e.tar.bz2
gentoo-89d02633a473d31ec655dc0b45ec72948687194e.zip
dev-libs/libreport: Version bump to 2.10.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/libreport/libreport-2.10.0.ebuild')
-rw-r--r--dev-libs/libreport/libreport-2.10.0.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-libs/libreport/libreport-2.10.0.ebuild b/dev-libs/libreport/libreport-2.10.0.ebuild
new file mode 100644
index 000000000000..d64adf865abf
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.10.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit autotools python-r1 user
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+gtk python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ >=dev-libs/glib-2.43.4:2
+ dev-libs/satyr:0=
+ dev-libs/json-c:=
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir \
+ econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ use python && python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ use python && python_foreach_impl run_in_build_dir default
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}