summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-10-31 09:25:14 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-10-31 09:25:51 -0400
commit1c92f4c78ec588a7e6718fb8bb02b403b471ecca (patch)
tree655365664ccbba0893df27578fdd2438e7295270 /dev-libs/libressl
parentdev-libs/libsigc++: bump to 2.20.1 (diff)
downloadgentoo-1c92f4c78ec588a7e6718fb8bb02b403b471ecca.tar.gz
gentoo-1c92f4c78ec588a7e6718fb8bb02b403b471ecca.tar.bz2
gentoo-1c92f4c78ec588a7e6718fb8bb02b403b471ecca.zip
dev-libs/libressl: version bump to 2.8.2
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-2.8.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index b2d45f30e38a..455b8db6538d 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -4,3 +4,4 @@ DIST libressl-2.7.3.tar.gz 3364724 BLAKE2B e245cd0e3c4819e12f3f05898429c10894959
DIST libressl-2.7.4.tar.gz 3359012 BLAKE2B 07b98fdc6bcdf9d888fb1b1d301c95ab6f998fb7ff2c6dfd2ecf4558768e200dfa96c394e5b321bc27ba390e92646c319ef5be5915872a7c086de8017ff8f855 SHA512 1cd82a1bff4f655251b5feb0c850f4164e0fd548e4b404407370f74dcc75c205f42efc7787a157eecac84cbbe46af48cb63f46b3fef75f4a0a9ea19a5863a691
DIST libressl-2.8.0.tar.gz 3377310 BLAKE2B 2a2027d86e99a09a349f3f123223a8544f49410ae53dbf4b97f898895758d00b1e8f73889f0b0ad8cec6f7ba5e85f033080d0e4af92b0fd10d048136337a0213 SHA512 3004cd78a9d52dece9f24272389778d6afca549de245852004ddd57b01a0c3a6fa1cee2d56980d067d23b3ead7f7a4aa6bcf4e0c57a56f5f7d9fd3f8d23f3ca2
DIST libressl-2.8.1.tar.gz 3375642 BLAKE2B 39b550e09cfe286e92c6b1168525bac927b37ed7c03db159e456e71abba1d411a78c7a3ad9084b28d41a3f132a959ea82e877ed159daa2c69fa59fef67fec1b8 SHA512 57af2c7a1a8522dca25c4e6371cb44f5ab074be1aded153e6e5fca4fa0844518710f7ce834d4dd309086686c492f10fca83f4d45c084eb49607cb5861f07ac99
+DIST libressl-2.8.2.tar.gz 3373599 BLAKE2B 61b774129ef93081b4a7c94a66fe696520a3f2922d58950e907ad9f047c9fa6495d7753c71d0bb3aec6aa266f16b75fd1d8d485fc3988b97d3d67893dd3db319 SHA512 bfcc55904efbb591c9edd56169d611e735108dfc6a49f771a64ad1ddd028d3a658f5593116c379911edc77f95eba475daec9c0adea0549e8b4b94d1072adf733
diff --git a/dev-libs/libressl/libressl-2.8.2.ebuild b/dev-libs/libressl/libressl-2.8.2.ebuild
new file mode 100644
index 000000000000..4ca27fb26c11
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.8.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/46"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ eapply_user
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}