summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-04-16 21:31:09 -0400
committerAaron Bauman <bman@gentoo.org>2018-04-16 21:31:09 -0400
commitccbc8eb528dabbf77dacba34e5ea545231a55b90 (patch)
treef3d1eedc976ff290c88d81b88034016040371b7e /dev-libs/libressl
parentdev-perl/Cwd-Guard: Cleanup old (diff)
downloadgentoo-ccbc8eb528dabbf77dacba34e5ea545231a55b90.tar.gz
gentoo-ccbc8eb528dabbf77dacba34e5ea545231a55b90.tar.bz2
gentoo-ccbc8eb528dabbf77dacba34e5ea545231a55b90.zip
dev-libs/libressl: enable REQUIRED_USE for tests and drop eutils
Upstream has noted that tests require static-libs. As such, require that static-libs USE flag is set. Additionally, drop eutils eclass in favor of ltprune as the only function called is prune_libtool_files. Closes: https://bugs.gentoo.org/625266 Closes: https://bugs.gentoo.org/607960 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/libressl-2.6.0.ebuild7
-rw-r--r--dev-libs/libressl/libressl-2.6.4.ebuild5
-rw-r--r--dev-libs/libressl/libressl-2.7.2.ebuild5
3 files changed, 9 insertions, 8 deletions
diff --git a/dev-libs/libressl/libressl-2.6.0.ebuild b/dev-libs/libressl/libressl-2.6.0.ebuild
index 44ecf27ddcb0..2613eb39b531 100644
--- a/dev-libs/libressl/libressl-2.6.0.ebuild
+++ b/dev-libs/libressl/libressl-2.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils multilib-minimal
+inherit ltprune multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
HOMEPAGE="https://www.libressl.org/"
@@ -15,14 +15,13 @@ LICENSE="ISC openssl"
# versions, we have to change the subslot to trigger rebuild of consumers.
SLOT="0/43"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="+asm static-libs"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
RDEPEND="!dev-libs/openssl:0"
DEPEND="${RDEPEND}"
PDEPEND="app-misc/ca-certificates"
-RESTRICT="test" # bug #625266
-
src_prepare() {
touch crypto/Makefile.in
diff --git a/dev-libs/libressl/libressl-2.6.4.ebuild b/dev-libs/libressl/libressl-2.6.4.ebuild
index b4987334136f..d8f2130d4b1a 100644
--- a/dev-libs/libressl/libressl-2.6.4.ebuild
+++ b/dev-libs/libressl/libressl-2.6.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils multilib-minimal
+inherit ltprune multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
HOMEPAGE="https://www.libressl.org/"
@@ -15,7 +15,8 @@ LICENSE="ISC openssl"
# versions, we have to change the subslot to trigger rebuild of consumers.
SLOT="0/44"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="+asm static-libs"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
RDEPEND="!dev-libs/openssl:0"
DEPEND="${RDEPEND}"
diff --git a/dev-libs/libressl/libressl-2.7.2.ebuild b/dev-libs/libressl/libressl-2.7.2.ebuild
index af207c40014f..d988e0c8f015 100644
--- a/dev-libs/libressl/libressl-2.7.2.ebuild
+++ b/dev-libs/libressl/libressl-2.7.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils multilib-minimal
+inherit ltprune multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
HOMEPAGE="https://www.libressl.org/"
@@ -16,7 +16,8 @@ LICENSE="ISC openssl"
SLOT="0/45"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
KEYWORDS=""
-IUSE="+asm static-libs"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
RDEPEND="!dev-libs/openssl:0"
DEPEND="${RDEPEND}"