summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-20 09:14:53 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-20 09:14:53 -0500
commitda7aa7d572979f7d603f142c2f44a6e3036a8672 (patch)
tree65cba2deb6ac931c73d64985f6af226cdb82a48b /dev-libs/libressl
parentnet-libs/webkit-gtk: security bump to 2.18.4 (diff)
downloadgentoo-da7aa7d572979f7d603f142c2f44a6e3036a8672.tar.gz
gentoo-da7aa7d572979f7d603f142c2f44a6e3036a8672.tar.bz2
gentoo-da7aa7d572979f7d603f142c2f44a6e3036a8672.zip
dev-libs/libressl: version bump to 2.6.4
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-2.6.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index 4945a6fb8083..81b98a301f54 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -7,3 +7,4 @@ DIST libressl-2.6.0.tar.gz 3297288 BLAKE2B 8906227a1d125e32afafb666e67c1364d7642
DIST libressl-2.6.1.tar.gz 3219005 BLAKE2B ca5c1b2f1c824f9faf26cf335a533b98a9af45f6567b63cff089cd8efd4c314d0c8d8402c0a19d7227eeec55667418d7a91e79c1fc1d2ac031eb634c0091a6ea SHA512 89f1a796c14bd479f20407254a0d787b4200b3b633f5c24e23f16751ff973ccbf3167d676ed13a5004614b5c8c3e1c73c89dce3d5b1e81890ef6ef2774df9b72
DIST libressl-2.6.2.tar.gz 3229140 BLAKE2B 65ee69ac9d5754a153ed8e9ca20240cf6d584093731a0fc53fc847f6c2a6516fa709f347ef58059a3dfde7a6013cef0188d6632a15ace172f6a371f1fcdb7756 SHA512 2896d52185b84edfb23eae73949f5a537966b42e659f00b0b2e0635e69daf546fc41e0e7b97cb52a85e73b2d27ead221a3225977f6b5ee998aefdabf0908a9e4
DIST libressl-2.6.3.tar.gz 3228661 BLAKE2B 01d1e09a5c4541e1d6b35d0a1cd9246671a7cda404c9818885cce55897dd405585a656b748ca6c959224b7d6155c20700fb4a92c37af42429959162a7ad8fb87 SHA512 5c0a0f86ecad1226c2d9a3a8a2e6f412ac0941d402c213ae1d293cd90c6a684198410db8c5250f83b8e2b00968a089afc39e90e053669fc27f82a4eb7c65f5c9
+DIST libressl-2.6.4.tar.gz 3227935 BLAKE2B 48e865448a9e5b0b604b06060091073276aebd376506de73773a5eb9cb0bb4c5b93aa16353b4892abaee97ec933ad77e89775c3f52263d77bb17c68e481b4f70 SHA512 181761da573ff392aaee17dd3dde416d7cbb299ab3e07b49c97e279ceb3f619e78d1dc9ec4c59b0af024f0a8270ff31fe37f8282d0392be34c3143c9647cd246
diff --git a/dev-libs/libressl/libressl-2.6.4.ebuild b/dev-libs/libressl/libressl-2.6.4.ebuild
new file mode 100644
index 000000000000..22abf48a53e9
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/44"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ eapply_user
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}