summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:22:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:43:04 +0200
commit57e9a270c3a65e4007a7990fbc56f677566d93be (patch)
tree70864db0ed5c7e5283570625921ccc88bc9fdf88 /dev-libs/librevenge/librevenge-9999.ebuild
parentprofiles: plasma: Update comment for sys-libs/zlib[minizip] (diff)
downloadgentoo-57e9a270c3a65e4007a7990fbc56f677566d93be.tar.gz
gentoo-57e9a270c3a65e4007a7990fbc56f677566d93be.tar.bz2
gentoo-57e9a270c3a65e4007a7990fbc56f677566d93be.zip
dev-libs/librevenge: EAPI-7 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/librevenge/librevenge-9999.ebuild')
-rw-r--r--dev-libs/librevenge/librevenge-9999.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/dev-libs/librevenge/librevenge-9999.ebuild b/dev-libs/librevenge/librevenge-9999.ebuild
index c40659225a0b..dfb84af90b75 100644
--- a/dev-libs/librevenge/librevenge-9999.ebuild
+++ b/dev-libs/librevenge/librevenge-9999.ebuild
@@ -1,30 +1,32 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic multilib-minimal
-DESCRIPTION="A helper library for REVerse ENGineered formats filters"
-HOMEPAGE="https://sf.net/p/libwpd/librevenge"
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/librevenge"
inherit git-r3 autotools
else
SRC_URI="https://sf.net/projects/libwpd/files/${PN}/${P}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
+DESCRIPTION="Helper library for REVerse ENGineered formats filters"
+HOMEPAGE="https://sf.net/p/libwpd/librevenge"
LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
SLOT="0"
IUSE="doc test"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
sys-libs/zlib[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
dev-libs/boost
- doc? ( app-doc/doxygen )
test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
"
@@ -37,15 +39,16 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-static
+ --disable-werror
+ $(use_with doc docs)
$(use_enable test tests)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}