summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-21 09:51:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-21 09:57:27 +0200
commit579c7a54e985423ecf1059b91ac107773a651e93 (patch)
tree24dae4205a1eafca658703715462cd00c4194f99 /dev-libs/libsass
parentdev-python/dogpile-cache: Bump to 1.1.3 (diff)
downloadgentoo-579c7a54e985423ecf1059b91ac107773a651e93.tar.gz
gentoo-579c7a54e985423ecf1059b91ac107773a651e93.tar.bz2
gentoo-579c7a54e985423ecf1059b91ac107773a651e93.zip
dev-libs/libsass: Bump to 3.6.5 (needed for dev-python/libsass)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libsass')
-rw-r--r--dev-libs/libsass/Manifest1
-rw-r--r--dev-libs/libsass/libsass-3.6.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libsass/Manifest b/dev-libs/libsass/Manifest
index b4e9805f66f5..ed2f36901647 100644
--- a/dev-libs/libsass/Manifest
+++ b/dev-libs/libsass/Manifest
@@ -1,2 +1,3 @@
DIST libsass-3.6.1.tar.gz 333609 BLAKE2B ea6cb0285a6d741614bb900ff0f3b74660c74ec9ed071abf2d980bfe3f55b02fa2873d3860e5b767ca82b5f202f3d2aef28b73357bf8d2b3117c925b4dc78791 SHA512 e9a3a30851e26145d049c4b20951c663a9d48c781a732acd3cc2cdb30df3449e445b57211f666b58afa137431fbdb149add48ff8a0dec92bd8abb514c90adebb
DIST libsass-3.6.4.tar.gz 338519 BLAKE2B 9d312e36e1ac40dcce3aa29728e66643de28da7f2244c8fc987c9a1de7fa0fa72fd5bbd4b5a218c9b53652bd0de469141dbf1b4ddecb7f98405965df946cf333 SHA512 1f79553be31949d45adf440dcbcf4b828a7e4f71c6f63f288f99451fccc490ebf0c68c58d91deabede37962e35a8cf9af8b0d60d89349fd0adea1ac061c8c2c8
+DIST libsass-3.6.5.tar.gz 342426 BLAKE2B 8c6bb37da3f832dd462408a7ef4f80384e468295fc420b3d915899e65fb89a9d0b4c1cf0653b7288fedbf6a66daa2943c2911ad2c310f77a06deb84bec1d3abf SHA512 98cc7e12fdf74cd9e92d8d4a62b821956d3ad186fcee9a8d77b677a621342aa161b73d9adad4c1849678a3bac890443120cc8febe1b7429aab374321d635b8f7
diff --git a/dev-libs/libsass/libsass-3.6.5.ebuild b/dev-libs/libsass/libsass-3.6.5.ebuild
new file mode 100644
index 000000000000..14f45c1d6db9
--- /dev/null
+++ b/dev-libs/libsass/libsass-3.6.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/sass/libsass.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
+HOMEPAGE="https://github.com/sass/libsass"
+LICENSE="MIT"
+SLOT="0/1" # libsass soname
+IUSE="static-libs"
+
+DOCS=( Readme.md SECURITY.md )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} != *9999 ]]; then
+ [[ -f VERSION ]] || echo "${PV}" > VERSION
+ fi
+ eautoreconf
+
+ # only sane way to deal with various version-related scripts, env variables etc.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-shared
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc -r "${S}/docs"
+}