summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:58 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:58 +0200
commitb70522335c001076efc45b3fa5382e5e579ae7fa (patch)
treea93d5fa4b913146c2d62b50d1d0e639a6ee3af46 /dev-libs/libsass
parentdev-libs/libretls: drop multilib (diff)
downloadgentoo-b70522335c001076efc45b3fa5382e5e579ae7fa.tar.gz
gentoo-b70522335c001076efc45b3fa5382e5e579ae7fa.tar.bz2
gentoo-b70522335c001076efc45b3fa5382e5e579ae7fa.zip
dev-libs/libsass: drop multilib, static-libs
No multilib or static-libs reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libsass')
-rw-r--r--dev-libs/libsass/libsass-3.6.5-r1.ebuild (renamed from dev-libs/libsass/libsass-3.6.5.ebuild)24
-rw-r--r--dev-libs/libsass/libsass-9999.ebuild28
2 files changed, 20 insertions, 32 deletions
diff --git a/dev-libs/libsass/libsass-3.6.5.ebuild b/dev-libs/libsass/libsass-3.6.5-r1.ebuild
index c1a6d0479eb3..80400548f196 100644
--- a/dev-libs/libsass/libsass-3.6.5.ebuild
+++ b/dev-libs/libsass/libsass-3.6.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/sass/libsass.git"
@@ -17,7 +17,6 @@ DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
HOMEPAGE="https://github.com/sass/libsass"
LICENSE="MIT"
SLOT="0/1" # libsass soname
-IUSE="static-libs"
DOCS=( Readme.md SECURITY.md )
@@ -27,27 +26,22 @@ src_prepare() {
if [[ ${PV} != *9999 ]]; then
[[ -f VERSION ]] || echo "${PV}" > VERSION
fi
- eautoreconf
- # only sane way to deal with various version-related scripts, env variables etc.
- multilib_copy_sources
+ eautoreconf
}
-multilib_src_configure() {
+src_configure() {
local myeconfargs=(
- $(use_enable static-libs static)
--enable-shared
)
econf "${myeconfargs[@]}"
}
-multilib_src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete || die
-}
+src_install() {
+ default
+
+ dodoc -r docs
-multilib_src_install_all() {
- einstalldocs
- dodoc -r "${S}/docs"
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-libs/libsass/libsass-9999.ebuild b/dev-libs/libsass/libsass-9999.ebuild
index 04fbd70077d4..80400548f196 100644
--- a/dev-libs/libsass/libsass-9999.ebuild
+++ b/dev-libs/libsass/libsass-9999.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/sass/libsass.git"
inherit git-r3
else
SRC_URI="https://github.com/sass/libsass/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux"
+ KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv x86 ~amd64-linux"
fi
DESCRIPTION="A C/C++ implementation of a Sass CSS compiler"
HOMEPAGE="https://github.com/sass/libsass"
LICENSE="MIT"
SLOT="0/1" # libsass soname
-IUSE="static-libs"
DOCS=( Readme.md SECURITY.md )
@@ -27,27 +26,22 @@ src_prepare() {
if [[ ${PV} != *9999 ]]; then
[[ -f VERSION ]] || echo "${PV}" > VERSION
fi
- eautoreconf
- # only sane way to deal with various version-related scripts, env variables etc.
- multilib_copy_sources
+ eautoreconf
}
-multilib_src_configure() {
+src_configure() {
local myeconfargs=(
- $(use_enable static-libs static)
--enable-shared
)
econf "${myeconfargs[@]}"
}
-multilib_src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete || die
-}
+src_install() {
+ default
+
+ dodoc -r docs
-multilib_src_install_all() {
- einstalldocs
- dodoc -r "${S}/docs"
+ find "${ED}" -name '*.la' -delete || die
}