summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-12-14 03:12:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2017-01-05 09:07:52 -0500
commit6a9223482e48c57fd8fc31381a3e7828a1153299 (patch)
tree80d4afa282c736447f838a9da714bca9d3c1ffd0 /dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
parentprofiles/arch/hppa: Fix comment. (diff)
downloadgentoo-6a9223482e48c57fd8fc31381a3e7828a1153299.tar.gz
gentoo-6a9223482e48c57fd8fc31381a3e7828a1153299.tar.bz2
gentoo-6a9223482e48c57fd8fc31381a3e7828a1153299.zip
dev-libs/libsecp256k1: Bump to 0.0.0_pre20161213 (and update 9999)
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-9999.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-9999.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
index cd430a4deb36..fa2726044e8e 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
@@ -14,22 +14,21 @@ HOMEPAGE="https://github.com/bitcoin/${MyPN}"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="asm doc ecdh endomorphism experimental gmp libressl +recovery schnorr test"
+IUSE="asm doc ecdh endomorphism experimental gmp java +recovery test test_openssl"
REQUIRED_USE="
- asm? ( amd64 )
+ asm? ( || ( amd64 arm ) arm? ( experimental ) )
ecdh? ( experimental )
- schnorr? ( experimental )
+ java? ( ecdh )
+ test_openssl? ( test )
"
RDEPEND="
gmp? ( dev-libs/gmp:0 )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
- test? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ java? ( virtual/jdk )
+ test_openssl? ( dev-libs/openssl:0 )
"
src_prepare() {
@@ -37,16 +36,27 @@ src_prepare() {
}
src_configure() {
+ local asm_opt
+ if use asm; then
+ if use arm; then
+ asm_opt=arm
+ else
+ asm_opt=auto
+ fi
+ else
+ asm_opt=no
+ fi
econf \
--disable-benchmark \
$(use_enable experimental) \
+ $(use_enable java jni) \
$(use_enable test tests) \
+ $(use_enable test_openssl openssl-tests) \
$(use_enable ecdh module-ecdh) \
$(use_enable endomorphism) \
- --with-asm=$(usex asm auto no) \
+ --with-asm=$asm_opt \
--with-bignum=$(usex gmp gmp no) \
$(use_enable recovery module-recovery) \
- $(use_enable schnorr module-schnorr) \
--disable-static
}