summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-19 22:17:18 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 11:42:50 -0400
commit9bb34f643733cccefef9ed8111e10d8e98f63f96 (patch)
treeed126cafd47229be877ff076cfefa5e494916557 /dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
parentkde-apps/kcalc: fix issue where kcalc appears not to start (diff)
downloadgentoo-9bb34f643733cccefef9ed8111e10d8e98f63f96.tar.gz
gentoo-9bb34f643733cccefef9ed8111e10d8e98f63f96.tar.bz2
gentoo-9bb34f643733cccefef9ed8111e10d8e98f63f96.zip
dev-libs/libsecp256k1: bump to 0.0.0_pre20151118 and update 9999
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-9999.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
index b0a109807c08..9a1a1de7de33 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,10 +14,12 @@ HOMEPAGE="https://github.com/bitcoin/${MyPN}"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="asm doc endomorphism gmp test"
+IUSE="asm doc ecdh endomorphism experimental gmp +recovery schnorr test"
REQUIRED_USE="
asm? ( amd64 )
+ ecdh? ( experimental )
+ schnorr? ( experimental )
"
RDEPEND="
gmp? ( dev-libs/gmp:0 )
@@ -34,10 +36,14 @@ src_prepare() {
src_configure() {
econf \
--disable-benchmark \
+ $(use_enable experimental) \
$(use_enable test tests) \
+ $(use_enable ecdh module-ecdh) \
$(use_enable endomorphism) \
--with-asm=$(usex asm auto no) \
--with-bignum=$(usex gmp gmp no) \
+ $(use_enable recovery module-recovery) \
+ $(use_enable schnorr module-schnorr) \
--disable-static
}