summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-02-03 09:04:32 +0100
committerUlrich Müller <ulm@gentoo.org>2021-02-03 09:22:53 +0100
commit67253aa511ef6e4a67f829630b80487ccb4b933d (patch)
tree08f3b741bd709ef69c3303094d1dca09bc20992a /dev-libs/libsigsegv/libsigsegv-2.13.ebuild
parentapp-misc/mc: drop old (diff)
downloadgentoo-67253aa511ef6e4a67f829630b80487ccb4b933d.tar.gz
gentoo-67253aa511ef6e4a67f829630b80487ccb4b933d.tar.bz2
gentoo-67253aa511ef6e4a67f829630b80487ccb4b933d.zip
dev-libs/libsigsegv: Version bump to 2.13
EAPI 7. Specify LICENSE more precisely. Disable static libs. Closes: https://bugs.gentoo.org/723202 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-libs/libsigsegv/libsigsegv-2.13.ebuild')
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/libsigsegv-2.13.ebuild b/dev-libs/libsigsegv/libsigsegv-2.13.ebuild
new file mode 100644
index 000000000000..5db18ac2c314
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for handling page faults in user mode"
+HOMEPAGE="https://www.gnu.org/software/libsigsegv/"
+SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PATCHES=(
+ # Bug #363503
+ "${FILESDIR}/${PN}-2.12-skip-stackoverflow-tests.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-shared --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${ED}/usr/$(get_libdir)"/*.la || die
+ dodoc AUTHORS ChangeLog* NEWS PORTING README
+}