summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-01-19 13:36:07 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-01-19 13:36:07 -0500
commitefd4e81c082cd6a97b2c85fa82a8cfe72adfa904 (patch)
treee1a73d13b0831db800e95cda650669539f336e9c /dev-libs/libsodium/libsodium-1.0.16-r2.ebuild
parentapp-emulation/lxd: Bump to 3.9 (diff)
downloadgentoo-efd4e81c082cd6a97b2c85fa82a8cfe72adfa904.tar.gz
gentoo-efd4e81c082cd6a97b2c85fa82a8cfe72adfa904.tar.bz2
gentoo-efd4e81c082cd6a97b2c85fa82a8cfe72adfa904.zip
dev-libs/libsodium: add support on musl
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libsodium/libsodium-1.0.16-r2.ebuild')
-rw-r--r--dev-libs/libsodium/libsodium-1.0.16-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.16-r2.ebuild b/dev-libs/libsodium/libsodium-1.0.16-r2.ebuild
index 393a0f21ab8e..fe6573407753 100644
--- a/dev-libs/libsodium/libsodium-1.0.16-r2.ebuild
+++ b/dev-libs/libsodium/libsodium-1.0.16-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,10 @@ multilib_src_configure() {
# --disable-pie is needed on x86, see bug #512734
if [[ "${MULTILIB_ABI_FLAG}" == "abi_x86_32" ]]; then
myconf="${myconf} --disable-pie"
+ # --disable-ssp is needed on musl x86
+ if use elibc_musl; then
+ myconf+="${myconf} --disable-ssp"
+ fi
fi
econf \