summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-02-06 19:47:01 +0100
committerSebastian Pipping <sping@gentoo.org>2022-02-06 19:47:01 +0100
commitd1648dc81f8266f97d8324ca7bfd1fef281d7277 (patch)
treee989f655846cc628f4037653b3fb4de1f3e269c2 /dev-libs/libspnav
parentdev-lang/spark: drop python deps (diff)
downloadgentoo-d1648dc81f8266f97d8324ca7bfd1fef281d7277.tar.gz
gentoo-d1648dc81f8266f97d8324ca7bfd1fef281d7277.tar.bz2
gentoo-d1648dc81f8266f97d8324ca7bfd1fef281d7277.zip
dev-libs/libspnav: 0.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-libs/libspnav')
-rw-r--r--dev-libs/libspnav/Manifest1
-rw-r--r--dev-libs/libspnav/libspnav-0.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libspnav/Manifest b/dev-libs/libspnav/Manifest
index be11295bb56b..9cedbf01f446 100644
--- a/dev-libs/libspnav/Manifest
+++ b/dev-libs/libspnav/Manifest
@@ -1 +1,2 @@
DIST libspnav-0.2.3.tar.gz 11985 BLAKE2B 134a0c3f7c9a7ef7c4f68910e0266880958e2b74e253b75237b0fa8d3e482bcd1f42e715b85f0ffca3a62103530e854090818564d9c241bfc55de039cc4883ee SHA512 b2c452d979d455fc99bfdc172c8a2408a6e8dc40acc52964fa64f4d75a8ee77dda12e5e212c0c4e07a0a24d055f16f85bb6ce6287e24e6bd0665de457e37e6a7
+DIST libspnav-0.3.tar.gz 12386 BLAKE2B 6598e0eb3cb41c9e13f0cb62715cd199d2fff0903d8f62726fa82227f2aa49f4dc41083929cbdde18974dfb08c23947158b465bb552c12ea8c9f9fd754962c2b SHA512 1bd61c1ccda37af9b3eaeda6d8f269777f7d13b1c3d3ed4d194b917199bd232d79c9513bcdae6fce6c298ad8460c095a98e3cfd98ee76e1852fc0e93e478c252
diff --git a/dev-libs/libspnav/libspnav-0.3.ebuild b/dev-libs/libspnav/libspnav-0.3.ebuild
new file mode 100644
index 000000000000..c4af54f4d64b
--- /dev/null
+++ b/dev-libs/libspnav/libspnav-0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_PN='spacenav'
+DESCRIPTION="libspnav is a replacement for the magellan library with a cleaner API"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="https://github.com/FreeSpacenav/libspnav/releases/download/v${PV}/libspnav-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="static-libs X"
+
+CDEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="app-misc/spacenavd[X?]
+ ${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+src_configure() {
+ local args=(
+ --disable-opt
+ --disable-debug
+ $(use_enable X x11)
+ )
+ econf "${args[@]}"
+}
+
+src_compile() {
+ local args=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ incpaths=-I.
+ libpaths=
+ )
+ emake "${args[@]}"
+}
+
+src_install() {
+ local args=(
+ DESTDIR="${D}"
+ libdir="$(get_libdir)"
+ )
+ emake "${args[@]}" install
+
+ # The custom configure script does not support --disable-static
+ # and conditionally patching $(lib_a) out of Makefile.in does not
+ # seem like a very maintainable option, hence we delete the .a file
+ # after "make install", instead.
+ use static-libs || find "${D}" -type f -name \*.a -delete
+}