summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-27 22:09:46 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-27 22:09:46 +0200
commitf13b25aeebb4fdf2a2f9ea15462f21341725629c (patch)
tree69733d55e60982f9518aae020385eac17d3a4856 /dev-libs/libtar
parentdev-libs/bcm2835: update EAPI 6 -> 8 (diff)
downloadgentoo-f13b25aeebb4fdf2a2f9ea15462f21341725629c.tar.gz
gentoo-f13b25aeebb4fdf2a2f9ea15462f21341725629c.tar.bz2
gentoo-f13b25aeebb4fdf2a2f9ea15462f21341725629c.zip
dev-libs/libtar: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libtar')
-rw-r--r--dev-libs/libtar/libtar-1.2.20-r5.ebuild (renamed from dev-libs/libtar/libtar-1.2.20-r4.ebuild)31
1 files changed, 12 insertions, 19 deletions
diff --git a/dev-libs/libtar/libtar-1.2.20-r4.ebuild b/dev-libs/libtar/libtar-1.2.20-r5.ebuild
index 087a633aa6f4..c9c26bbb3adb 100644
--- a/dev-libs/libtar/libtar-1.2.20-r4.ebuild
+++ b/dev-libs/libtar/libtar-1.2.20-r5.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="C library for manipulating tar archives"
HOMEPAGE="https://repo.or.cz/w/libtar.git/"
SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="static-libs zlib"
+IUSE="zlib"
+# There is no test and 'check' target errors out due to mixing of automake &
+# non-automake makefiles.
+# https://bugs.gentoo.org/526436
+RESTRICT="test"
RDEPEND="
zlib? ( sys-libs/zlib:= )
- !zlib? ( app-arch/gzip )
-"
+ !zlib? ( app-arch/gzip )"
DEPEND="${RDEPEND}"
-DOCS=( ChangeLog{,-1.0.x} README TODO )
-
-S="${WORKDIR}/${PN}"
-
-# There is no test and 'check' target errors out due to mixing of automake &
-# non-automake makefiles.
-# https://bugs.gentoo.org/show_bug.cgi?id=526436
-RESTRICT="test"
-
PATCHES=(
"${FILESDIR}"/${PN}-1.2.11-free.patch
"${FILESDIR}"/${PN}-1.2.11-impl-dec.patch
@@ -49,22 +44,20 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --enable-shared
--disable-encap
--disable-epkg-install
- $(use_enable static-libs static)
$(use_with zlib)
)
- econf ${myeconfargs[@]}
+ econf "${myeconfargs[@]}"
}
src_install() {
default
-
+ dodoc ChangeLog-1.0.x
newdoc compat/README README.compat
newdoc compat/TODO TODO.compat
newdoc listhash/TODO TODO.listhash
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}