summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-07 14:30:43 +0000
committerSam James <sam@gentoo.org>2022-12-07 14:30:43 +0000
commit9ccc798ee0f285317f413cdb3ea4e9cd1eb2b874 (patch)
tree30bb1a4baa1002eef1d543ccf50e58ef795d3823 /dev-libs/libtecla/libtecla-1.6.3-r1.ebuild
parentdev-libs/zthread: EAPI 8, fix configure w/ clang 16 (diff)
downloadgentoo-9ccc798ee0f285317f413cdb3ea4e9cd1eb2b874.tar.gz
gentoo-9ccc798ee0f285317f413cdb3ea4e9cd1eb2b874.tar.bz2
gentoo-9ccc798ee0f285317f413cdb3ea4e9cd1eb2b874.zip
dev-libs/libtecla: EAPI 8, fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libtecla/libtecla-1.6.3-r1.ebuild')
-rw-r--r--dev-libs/libtecla/libtecla-1.6.3-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libtecla/libtecla-1.6.3-r1.ebuild b/dev-libs/libtecla/libtecla-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..4487a6f6dfe6
--- /dev/null
+++ b/dev-libs/libtecla/libtecla-1.6.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Tecla command-line editing library"
+HOMEPAGE="https://www.astro.caltech.edu/~mcs/tecla/"
+SRC_URI="https://www.astro.caltech.edu/~mcs/tecla/${P}.tar.gz"
+S="${WORKDIR}"/libtecla
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~riscv x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install.patch
+ "${FILESDIR}"/${PN}-1.6.1-no-strip.patch
+ "${FILESDIR}"/${PN}-1.6.3-ldflags.patch
+ "${FILESDIR}"/${PN}-1.6.3-prll-build.patch
+ "${FILESDIR}"/${PN}-1.6.1-prll-install.patch
+ "${FILESDIR}"/${PN}-1.6.3-static-libs.patch
+ "${FILESDIR}"/${PN}-1.6.3-secure-runpath.patch
+ "${FILESDIR}"/${PN}-1.6.3-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs)
+}
+
+src_compile() {
+ emake \
+ OPT="" \
+ LDFLAGS="${LDFLAGS}" \
+ LFLAGS="$(raw-ldflags)"
+}