summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-01-12 23:50:43 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-02-19 15:32:14 +0200
commit42f7a28c7231bb4e3d17c73eace7989eae533c20 (patch)
tree043ea2620828d5707fafa8d2a0df6fd9402f2afa /dev-libs/libtpms
parentgames-strategy/freeciv: "|| die" where QA wants it (diff)
downloadgentoo-42f7a28c7231bb4e3d17c73eace7989eae533c20.tar.gz
gentoo-42f7a28c7231bb4e3d17c73eace7989eae533c20.tar.bz2
gentoo-42f7a28c7231bb4e3d17c73eace7989eae533c20.zip
dev-libs/libtpms: Add libressl support
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/libtpms-0.7.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libtpms/libtpms-0.7.0-r1.ebuild b/dev-libs/libtpms/libtpms-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..b13d07d50237
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.7.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND=" !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}