summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-31 16:19:44 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-31 16:27:34 -0400
commit19f7c1da8a5608f8f5f150c5add3c57fc812d10d (patch)
tree053152ff892be15261786430a9a8f56ac755d104 /dev-libs/libudfread/libudfread-1.1.1.ebuild
parentmedia-plugins/kodi-inputstream-adaptive: 2.6.3 version bump (diff)
downloadgentoo-19f7c1da8a5608f8f5f150c5add3c57fc812d10d.tar.gz
gentoo-19f7c1da8a5608f8f5f150c5add3c57fc812d10d.tar.bz2
gentoo-19f7c1da8a5608f8f5f150c5add3c57fc812d10d.zip
dev-libs/libudfread: 1.1.1 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libudfread/libudfread-1.1.1.ebuild')
-rw-r--r--dev-libs/libudfread/libudfread-1.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libudfread/libudfread-1.1.1.ebuild b/dev-libs/libudfread/libudfread-1.1.1.ebuild
new file mode 100644
index 000000000000..f4fb055b98c6
--- /dev/null
+++ b/dev-libs/libudfread/libudfread-1.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}