summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-13 11:24:24 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-13 13:04:20 -0500
commit4fef32d2f537832732df7851801ff107af13ecbb (patch)
tree36cd18c1031991c20aa490b84893d9878490124d /dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
parentdev-libs/libparserutils: drop netsurf eclass (diff)
downloadgentoo-4fef32d2f537832732df7851801ff107af13ecbb.tar.gz
gentoo-4fef32d2f537832732df7851801ff107af13ecbb.tar.bz2
gentoo-4fef32d2f537832732df7851801ff107af13ecbb.zip
dev-libs/libutf8proc: drop netsurf eclass
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild')
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
new file mode 100644
index 000000000000..bfc2a2dc1b40
--- /dev/null
+++ b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="mapping tool for UTF-8 strings"
+HOMEPAGE="http://www.netsurf-browser.org/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-util/netsurf-buildsystem"
+
+S="${WORKDIR}/${MY_P}"
+
+_emake() {
+ source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+}