summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-03-03 23:20:52 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-03-03 23:22:25 +0900
commitdf1ced9d116ae9c4b3459471131c791c9cf3703a (patch)
tree7debb5b6863a571e2531ea4484b96f4b11f14bc7 /dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild
parentdev-python/nbval: add missing dev-python/sympy test dep (diff)
downloadgentoo-df1ced9d116ae9c4b3459471131c791c9cf3703a.tar.gz
gentoo-df1ced9d116ae9c4b3459471131c791c9cf3703a.tar.bz2
gentoo-df1ced9d116ae9c4b3459471131c791c9cf3703a.zip
dev-libs/libutf8proc: fix tests
Closes: https://bugs.gentoo.org/773391 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild')
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild
index 323f38181fb6..c3a247d61225 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.6.1.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+USE_RUBY="ruby25 ruby26 ruby27"
-inherit toolchain-funcs
+inherit ruby-single toolchain-funcs
DESCRIPTION="A clean C Library for processing UTF-8 Unicode data"
HOMEPAGE="https://github.com/JuliaStrings/utf8proc"
@@ -16,7 +17,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-cyg
IUSE="cjk static-libs test"
RESTRICT="!test? ( test )"
-BDEPEND="test? ( =app-i18n/unicode-data-13.0* )"
+BDEPEND="test? (
+ =app-i18n/unicode-data-13.0*
+ ${RUBY_DEPS}
+ )"
S="${WORKDIR}/${P#lib}"
src_prepare() {