summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-20 13:17:58 -0700
committerMichał Górny <mgorny@gentoo.org>2019-09-26 19:34:23 +0200
commit7d094cf109744986803600ba63f0e021ae8e00a7 (patch)
treea3a2fe4cee174ba20d1babfc217b538bd3b799de /dev-libs/libvterm/libvterm-0.1.1.ebuild
parentdev-libs/libvterm: yank 0.0_pre20171004 (diff)
downloadgentoo-7d094cf109744986803600ba63f0e021ae8e00a7.tar.gz
gentoo-7d094cf109744986803600ba63f0e021ae8e00a7.tar.bz2
gentoo-7d094cf109744986803600ba63f0e021ae8e00a7.zip
dev-libs/libvterm: bump 0.1.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libvterm/libvterm-0.1.1.ebuild')
-rw-r--r--dev-libs/libvterm/libvterm-0.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libvterm/libvterm-0.1.1.ebuild b/dev-libs/libvterm/libvterm-0.1.1.ebuild
new file mode 100644
index 000000000000..a9f83554b9e2
--- /dev/null
+++ b/dev-libs/libvterm/libvterm-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
+HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
+SRC_URI="https://launchpad.net/${PN}/trunk/v$(ver_cut 1-2)/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+DEPEND=""
+RDEPEND="!dev-libs/libvterm-neovim"
+
+src_compile() {
+ append-cflags -fPIC
+ emake VERBOSE=1 PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake \
+ VERBOSE=1 \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
+}