summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 13:32:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:35:06 +0200
commit9f2eb91a522dca1e16909d395cd3eee369c7acb6 (patch)
treeae1ef809e36531dacf087d3426f8158f632848ce /dev-libs/libwacom/libwacom-1.11.ebuild
parentgames-action/minecraft-launcher: add missing dependency (diff)
downloadgentoo-9f2eb91a522dca1e16909d395cd3eee369c7acb6.tar.gz
gentoo-9f2eb91a522dca1e16909d395cd3eee369c7acb6.tar.bz2
gentoo-9f2eb91a522dca1e16909d395cd3eee369c7acb6.zip
dev-libs/libwacom: 1.11 version bump
- EAPI-8 - python3_10 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libwacom/libwacom-1.11.ebuild')
-rw-r--r--dev-libs/libwacom/libwacom-1.11.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/libwacom/libwacom-1.11.ebuild b/dev-libs/libwacom/libwacom-1.11.ebuild
new file mode 100644
index 000000000000..de40b8c9ca0d
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-1.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 toolchain-funcs udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pyudev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ tc-ld-disable-gold # bug https://github.com/linuxwacom/libwacom/issues/170
+
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}