summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-20 11:57:42 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-20 12:27:41 -0400
commit2aefd829c5e4be8d2b086fa375ab8ba8d13b90ca (patch)
treee9605856a7af76ad3e63baac35b5eb2b9c8e598f /dev-libs/libwacom/libwacom-1.9.ebuild
parentx11-apps/xkbcomp: Version bump to 1.4.5 (diff)
downloadgentoo-2aefd829c5e4be8d2b086fa375ab8ba8d13b90ca.tar.gz
gentoo-2aefd829c5e4be8d2b086fa375ab8ba8d13b90ca.tar.bz2
gentoo-2aefd829c5e4be8d2b086fa375ab8ba8d13b90ca.zip
dev-libs/libwacom: Version bump to 1.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libwacom/libwacom-1.9.ebuild')
-rw-r--r--dev-libs/libwacom/libwacom-1.9.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/libwacom/libwacom-1.9.ebuild b/dev-libs/libwacom/libwacom-1.9.ebuild
new file mode 100644
index 000000000000..0c54c6c491e4
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-1.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-any-r1 toolchain-funcs udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pyudev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ tc-ld-disable-gold # bug https://github.com/linuxwacom/libwacom/issues/170
+
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ -Dudev-dir=$(get_udevdir)
+
+ )
+ meson_src_configure
+}