summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libwacom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libwacom')
-rw-r--r--dev-libs/libwacom/Manifest3
-rw-r--r--dev-libs/libwacom/libwacom-0.11.ebuild47
-rw-r--r--dev-libs/libwacom/libwacom-0.12.ebuild47
-rw-r--r--dev-libs/libwacom/libwacom-0.13.ebuild46
-rw-r--r--dev-libs/libwacom/metadata.xml11
5 files changed, 154 insertions, 0 deletions
diff --git a/dev-libs/libwacom/Manifest b/dev-libs/libwacom/Manifest
new file mode 100644
index 000000000000..42882caf27af
--- /dev/null
+++ b/dev-libs/libwacom/Manifest
@@ -0,0 +1,3 @@
+DIST libwacom-0.11.tar.bz2 424554 SHA256 995f192e53f09444b79b66986227ebbac477520956363dededa19af3d8746284 SHA512 465f1ea9354bcba7d1c5d9fe146192b7ba1593973690718b2584b4786feb434f672556e7eed799761f96a37fe79bd14ae33ab7695d3ce9d5214cf9bc5b26eecc WHIRLPOOL 7f29b09a9bdee0d9cb2f5712414bdbcccf1b2a31a387020de2c1f911411934a3ae61a1d430b40e3402282fbc60e0d184b82c1cd524e43c8417d678f27063f607
+DIST libwacom-0.12.tar.bz2 441360 SHA256 487baeb0b2067fd8ae3871e4a5971684878a35bb5f9c63d6a34fcc7612004d08 SHA512 1dcb7fd8ac9230410f4a582d4150856845a4f4ab545dae331b25efa634161b900c39b6a379174f795b692d2ef6b3887b6e5c175b73c3cfdfc37b182ff0218872 WHIRLPOOL 147dc4f0d834e64e4b2dbd7848abc50a38da7b15bf7e93f76e0a109ae412b4f0cd24053f4694f2703de4d07acdbfb7cc199ebd193e3ab13b2aa9b57498d16a0a
+DIST libwacom-0.13.tar.bz2 439767 SHA256 976b8801007ac96c6512751a0ef6903b482cd361f256965c2884196c88788176 SHA512 8474e4da6d4d44cb4dd2db2c203e9e57c646328b25bb0009e91cc358833f64052a24b6e8f9507d3459014ffebccc4b50c99a0f5d6c97b9b5a19c135a165aeba0 WHIRLPOOL 2c88a953aebed3596f6172a3c76c34516fda410770bb7a815ded02ca657fe3e6cf55fdd4dd5529df9cd9ebb9325886c78228b7cb9dbf970e2858fa5d31ab5c3a
diff --git a/dev-libs/libwacom/libwacom-0.11.ebuild b/dev-libs/libwacom/libwacom-0.11.ebuild
new file mode 100644
index 000000000000..c95fcfd1e9c5
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-0.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ local udevdir="$(get_udevdir)"
+ dodir "${udevdir}/rules.d"
+ # generate-udev-rules must be run from inside tools directory
+ pushd tools > /dev/null
+ ./generate-udev-rules > "${ED}/${udevdir}/rules.d/65-libwacom.rules" ||
+ die "generating udev rules failed"
+ popd > /dev/null
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}
diff --git a/dev-libs/libwacom/libwacom-0.12.ebuild b/dev-libs/libwacom/libwacom-0.12.ebuild
new file mode 100644
index 000000000000..860cbc28a9b9
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-0.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ local udevdir="$(get_udevdir)"
+ dodir "${udevdir}/rules.d"
+ # generate-udev-rules must be run from inside tools directory
+ pushd tools > /dev/null
+ ./generate-udev-rules > "${ED}/${udevdir}/rules.d/65-libwacom.rules" ||
+ die "generating udev rules failed"
+ popd > /dev/null
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}
diff --git a/dev-libs/libwacom/libwacom-0.13.ebuild b/dev-libs/libwacom/libwacom-0.13.ebuild
new file mode 100644
index 000000000000..6165dab9e505
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-0.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ local udevdir="$(get_udevdir)"
+ dodir "${udevdir}/rules.d"
+ # generate-udev-rules must be run from inside tools directory
+ pushd tools > /dev/null
+ ./generate-udev-rules > "${ED}/${udevdir}/rules.d/65-libwacom.rules" || die "generating udev rules failed"
+ popd > /dev/null
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}
diff --git a/dev-libs/libwacom/metadata.xml b/dev-libs/libwacom/metadata.xml
new file mode 100644
index 000000000000..ad51e5e10a70
--- /dev/null
+++ b/dev-libs/libwacom/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">linuxwacom</remote-id>
+ </upstream>
+</pkgmetadata>