summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-26 13:30:25 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-26 13:30:35 +0100
commit0a9faa3ea7098fc6a4370dbb89a48cd14eb4006f (patch)
tree2e65504746be39354503abe80acef0cc89e3ddbc /dev-libs/libwbxml/libwbxml-0.11.7.ebuild
parentwww-servers/apache: Removed unnecessary slash strip (diff)
downloadgentoo-0a9faa3ea7098fc6a4370dbb89a48cd14eb4006f.tar.gz
gentoo-0a9faa3ea7098fc6a4370dbb89a48cd14eb4006f.tar.bz2
gentoo-0a9faa3ea7098fc6a4370dbb89a48cd14eb4006f.zip
dev-libs/libwbxml: 0.11.7 bump
Switch to cmake eclass and github SRC_URI Closes: https://bugs.gentoo.org/767241 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-libs/libwbxml/libwbxml-0.11.7.ebuild')
-rw-r--r--dev-libs/libwbxml/libwbxml-0.11.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libwbxml/libwbxml-0.11.7.ebuild b/dev-libs/libwbxml/libwbxml-0.11.7.ebuild
new file mode 100644
index 000000000000..55fd805f9931
--- /dev/null
+++ b/dev-libs/libwbxml/libwbxml-0.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Library and tools to parse, encode and handle WBXML documents"
+HOMEPAGE="https://github.com/libwbxml/libwbxml"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/expat
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS=( BUGS ChangeLog README References THANKS TODO )
+S=${WORKDIR}/${PN}-${P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_INSTALL_DOC=OFF
+ -DENABLE_UNIT_TEST=$(usex test)
+ )
+
+ cmake_src_configure
+}