summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-28 20:28:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-28 20:31:41 +0000
commit4bbc0bd925e32087de9c61bf2bee81d00ec1ad7f (patch)
tree72d7009d23e1e8b2562290fd0fec913837e60043 /dev-libs/libxls/libxls-1.4.0-r1.ebuild
parentsys-kernel/hardened-sources: remove older versions (diff)
downloadgentoo-4bbc0bd925e32087de9c61bf2bee81d00ec1ad7f.tar.gz
gentoo-4bbc0bd925e32087de9c61bf2bee81d00ec1ad7f.tar.bz2
gentoo-4bbc0bd925e32087de9c61bf2bee81d00ec1ad7f.zip
dev-libs/libxls: fix infinite loop on excel files with 65535 rows
Reported-by: globus Bug: https://bugs.gentoo.org/607094 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libxls/libxls-1.4.0-r1.ebuild')
-rw-r--r--dev-libs/libxls/libxls-1.4.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libxls/libxls-1.4.0-r1.ebuild b/dev-libs/libxls/libxls-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..bb23a6c7517e
--- /dev/null
+++ b/dev-libs/libxls/libxls-1.4.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A library which can read Excel (xls) files"
+HOMEPAGE="http://libxls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/libxls/${P}.zip"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0/1" # libxlsreader.so.1
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT=test # test driver is missing
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-asprintf.patch
+ "${FILESDIR}"/${P}-infinite.patch
+)
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}