summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-18 02:18:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-18 02:36:04 +0200
commit5d4376a3a12d3285af362defa5901db599d1e277 (patch)
tree4ea6a3e6910eb3c164f0bb46a68cfe6d0ce98575 /dev-libs/log4cplus/log4cplus-1.2.0.ebuild
parentdev-libs/log4cplus: Version bump to 1.1.3-rc7 (diff)
downloadgentoo-5d4376a3a12d3285af362defa5901db599d1e277.tar.gz
gentoo-5d4376a3a12d3285af362defa5901db599d1e277.tar.bz2
gentoo-5d4376a3a12d3285af362defa5901db599d1e277.zip
dev-libs/log4cplus: Version bump to 1.2.0
Gentoo-bug: 594102 * EAPI=6 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/log4cplus/log4cplus-1.2.0.ebuild')
-rw-r--r--dev-libs/log4cplus/log4cplus-1.2.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/log4cplus/log4cplus-1.2.0.ebuild b/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
new file mode 100644
index 000000000000..8ad20f852616
--- /dev/null
+++ b/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="C++ port of the Log for Java (log4j) logging library"
+HOMEPAGE="http://log4cplus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}-stable/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+SLOT="0/1.2-5"
+KEYWORDS="~amd64 ~x86"
+IUSE="iconv qt4 threads working-locale working-c-locale"
+REQUIRED_USE="?? ( iconv working-locale working-c-locale )"
+
+RDEPEND="iconv? ( virtual/libiconv )
+ qt4? ( dev-qt/qtcore:4 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable threads) \
+ $(use_with iconv) \
+ $(use_with working-locale) \
+ $(use_with working-c-locale) \
+ $(use_with qt4 qt)
+}
+
+src_test() {
+ cd tests/ || die
+
+ local t
+ for t in appender customloglevel fileappender filter \
+ hierarchy loglog ndc ostream patternlayout performance priority \
+ propertyconfig timeformat; do
+ einfo "Running test \"${t}_test\""
+ pushd "${t}_test/" >/dev/null || die
+ "${S}"/${t}_test || die "Running ${t}_test failed!"
+ popd >/dev/null || die
+ done
+
+ if use threads; then
+ for t in configandwatch thread; do
+ einfo "Running test \"${t}_test\""
+ pushd "${t}_test/" >/dev/null || die
+ "${S}"/${t}_test || die "Running ${t}_test failed!"
+ popd >/dev/null || die
+ done
+ fi
+}
+
+src_install() {
+ default
+ dodoc docs/unicode.txt
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}