summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-01-10 14:12:28 +1100
committerMark Wright <gienah@gentoo.org>2020-01-10 19:43:16 +1100
commitc6e861e430f795dd862fe05fed3f93ef2ca298a9 (patch)
tree09cac871c46e95368a4339c6692544a65c0649af /dev-libs/mathjax
parentapp-doc/mathjax-docs: Add for dev-libs/mathjax USE=doc (diff)
downloadgentoo-c6e861e430f795dd862fe05fed3f93ef2ca298a9.tar.gz
gentoo-c6e861e430f795dd862fe05fed3f93ef2ca298a9.tar.bz2
gentoo-c6e861e430f795dd862fe05fed3f93ef2ca298a9.zip
dev-libs/mathjax: Bump to 2.7.7, fix USE=doc
Thanks to Arfrever Frehtes Taifersar Arahesis for reporting. Closes: https://bugs.gentoo.org/show_bug.cgi?id=526128 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/Manifest1
-rw-r--r--dev-libs/mathjax/mathjax-2.7.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
index 60e9420aa42d..ce20ad49d1e2 100644
--- a/dev-libs/mathjax/Manifest
+++ b/dev-libs/mathjax/Manifest
@@ -1,2 +1,3 @@
DIST mathjax-2.7.0.tar.gz 24594403 BLAKE2B 7cadfe7565a7ebba3569fb298a097f07081926b843a06c3c32447757eb0a5d463d654f20c42821010c81c59819bb14fdc5e84a39e87106bb6808bd6c9ca52bb7 SHA512 2a7c2b4a4991485c18f78dda4115da05a31c1a2d952c403726e99d22fd26f166298199238ad482e53b63b5414be687f325b586f5ebe4e2d552447c929415b350
DIST mathjax-2.7.4.tar.gz 25355532 BLAKE2B 0bed5224356757c64989de8b9355f5c2505f1fa951456c52caf1cc0a9b5a864633ce5299cc9b67b1e5c743e39bcb6aee787a76d6871fc998b614d62e12499f6f SHA512 cddc4c64c188620307f0ede3b0bc7ba071f78702ba6315426d8c83129543a6b81a3a9a115f88017e23b5094b7aefd934c39aeec9688419830e33f9fd0fb1de7e
+DIST mathjax-2.7.7.tar.gz 25347766 BLAKE2B c1f11bc854c95888d7f04ee627094a2e297e7554b0380dab30c08e2c4405495df611b440da0efd1e6456150513e07fa4ef90808d2332f9fb83785c118228de18 SHA512 471bd22475827a13d79de7d335f3e51ace06dfc04f575e8829b4505f428949f1dbe58798635cb434ed02ae0cd3fd8d1d577196b4961365fbcb399cc075d3284f
diff --git a/dev-libs/mathjax/mathjax-2.7.7.ebuild b/dev-libs/mathjax/mathjax-2.7.7.ebuild
new file mode 100644
index 000000000000..85f1f957063e
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.7.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-clean
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="doc? ( app-doc/mathjax-docs:${SLOT} )"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( README.md )
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ dosym ../${PN}-docs-${SLOT}/html /usr/share/doc/${P}/html
+ fi
+
+ default
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r test/*
+ fi
+ rm -r test docs LICENSE README.md || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}