summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-03-12 16:57:16 +0000
committerMatthew Smith <matthew@gentoo.org>2022-03-12 17:33:29 +0000
commit16891cfa0be41d8d755ab25497af1b734ccc7039 (patch)
tree6269804d462b076573cea8e6a5425b5c70712c1e /dev-libs/mimalloc
parentmedia-libs/assimp: bump to 5.2.2 (diff)
downloadgentoo-16891cfa0be41d8d755ab25497af1b734ccc7039.tar.gz
gentoo-16891cfa0be41d8d755ab25497af1b734ccc7039.tar.bz2
gentoo-16891cfa0be41d8d755ab25497af1b734ccc7039.zip
dev-libs/mimalloc: set MI_BUILD_{STATIC,OBJECT}=OFF
Deleting the static library post-installation breaks the CMake module. Also set MI_BUILD_OBJECT=OFF to not waste time building it. Acked-by: Sam James <sam@gentoo.org> Signed-off-by: Matthew Smith <matthew@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/24512 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-libs/mimalloc')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.5-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.0.5-r2.ebuild b/dev-libs/mimalloc/mimalloc-2.0.5-r2.ebuild
new file mode 100644
index 000000000000..b6ebdbf5a528
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.5-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="mimalloc is a compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}