summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-20 04:43:23 +0000
committerSam James <sam@gentoo.org>2021-12-20 04:44:18 +0000
commit879fd4f07351597f94384c9e55d33747ee480c31 (patch)
tree8c862f994cab78460c2b3e4a82226313e5f97ce0 /dev-libs/mimalloc
parentdev-util/bear: add libtool test dep and gcc11 patch (diff)
downloadgentoo-879fd4f07351597f94384c9e55d33747ee480c31.tar.gz
gentoo-879fd4f07351597f94384c9e55d33747ee480c31.tar.bz2
gentoo-879fd4f07351597f94384c9e55d33747ee480c31.zip
dev-libs/mimalloc: add 2.0.3
Closes: https://bugs.gentoo.org/820812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/mimalloc')
-rw-r--r--dev-libs/mimalloc/Manifest1
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index a15a6b0e7fda..3ca71f19477a 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1,2 +1,3 @@
DIST mimalloc-1.7.2.tar.gz 903317 BLAKE2B 6983a575c8e3a9ee92acc0042bc229805b7090794de6e693ff1cc344cd50e333d46f23663fbd16647ae4442b28f24bdc2043b46ed2bc16e13c3f8def08b155bb SHA512 5d78c5cc00dfff3dd7eb4bb59e8eff32397f5110d1183b4656cb56c40b88e2e648e3b18338119412b95ba9526937b16fce3aa4732f241a61a546e2bcea1efc9d
DIST mimalloc-1.7.3.tar.gz 908042 BLAKE2B 6a96fc33148261e3f69a55196725bb2cf2e45f08a668b3d74fd6e06f808c1ce40fbb4783c5df50abe58dbae8b9c1dd264e6fcc6cce0a259b2cbec397d4667736 SHA512 e5a17b98d77a27d2a544869c2e0302a7e3bf77b5b494b2ee8ddc7af18bf9da152fea41702a8a17eb7e128238259fba6f96fa5bac549f5927453dc9a0bc06d013
+DIST mimalloc-2.0.3.tar.gz 917461 BLAKE2B 4b803881ab75afa358cb2dd251268c0934472074bf1983c3851a9d4f8c8ec0ea3907b52c40b0efe1cc09916cf4c5aa93f786a606e0b999536118b91bb5800310 SHA512 275a5249d09a57c9a039714fc6eef24ae778496954972419f3ac8e33f3d12e9837ba0691a3c08a4ab807c26b868aad3a5b2c28ee10ecaa60fe21ffe1d416f08f
diff --git a/dev-libs/mimalloc/mimalloc-2.0.3.ebuild b/dev-libs/mimalloc/mimalloc-2.0.3.ebuild
new file mode 100644
index 000000000000..3cebd14d2d43
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="mimalloc is a compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}/usr/$(get_libdir)/mimalloc.o" || die
+
+ find "${ED}" -name '*.a' -delete || die
+}