summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/nettle/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/nettle/files')
-rw-r--r--dev-libs/nettle/files/nettle-2.7-shared.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/nettle/files/nettle-2.7-shared.patch b/dev-libs/nettle/files/nettle-2.7-shared.patch
new file mode 100644
index 000000000000..9b9d6c884d14
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.7-shared.patch
@@ -0,0 +1,77 @@
+--- nettle-2.7/examples/Makefile.in
++++ nettle-2.7/examples/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ OPENSSL_LIBFLAGS = @OPENSSL_LIBFLAGS@
+ BENCH_LIBS = @BENCH_LIBS@ -lm
+@@ -117,8 +117,8 @@
+ -lhogweed -lnettle $(BENCH_LIBS) $(LIBS) $(OPENSSL_LIBFLAGS) \
+ -o hogweed-benchmark$(EXEEXT)
+
+-$(TARGETS) : io.$(OBJEXT) ../libnettle.a
+-$(HOGWEED_TARGETS): ../libhogweed.a
++$(TARGETS) : io.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
++$(HOGWEED_TARGETS): ../$(LIBHOGWEED_FORLINK)
+
+ check: $(TS_ALL)
+ LD_LIBRARY_PATH=../.lib PATH="../.lib:$$PATH" srcdir="$(srcdir)" \
+--- nettle-2.7/testsuite/Makefile.in
++++ nettle-2.7/testsuite/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ TS_NETTLE_SOURCES = aes-test.c arcfour-test.c arctwo-test.c \
+ blowfish-test.c cast128-test.c \
+@@ -96,7 +96,7 @@
+ include $(srcdir)/.test-rules.make
+
+ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
+- ../libnettle.a @IF_HOGWEED@ ../libhogweed.a
++ ../$(LIBNETTLE_FORLINK) @IF_HOGWEED@ ../$(LIBHOGWEED_FORLINK)
+
+ # For use as, e.g.,
+ #
+--- nettle-2.7/tools/Makefile.in
++++ nettle-2.7/tools/Makefile.in
+@@ -15,7 +15,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ HOGWEED_TARGETS = pkcs1-conv$(EXEEXT)
+ TARGETS = sexp-conv$(EXEEXT) nettle-hash$(EXEEXT) nettle-lfib-stream$(EXEEXT) \
+@@ -34,19 +34,19 @@
+ DISTFILES = $(SOURCES) Makefile.in input.h misc.h output.h parse.h
+
+ sexp_conv_OBJS = $(sexp_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../libnettle.a
++sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(sexp_conv_OBJS) -lnettle $(LIBS) -o $@
+
+-nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../libnettle.a
++nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
+ $(LINK) nettle-lfib-stream.$(OBJEXT) -lnettle $(LIBS) -o $@
+
+ pkcs1_conv_OBJS = $(pkcs1_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../libnettle.a ../libhogweed.a
++pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../$(LIBNETTLE_FORLINK) ../$(LIBHOGWEED_FORLINK)
+ $(LINK) $(pkcs1_conv_OBJS) -lhogweed -lnettle $(LIBS) -o $@
+
+ # FIXME: Avoid linking with gmp
+ nettle_hash_OBJS = $(nettle_hash_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../libnettle.a
++nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(nettle_hash_OBJS) -lnettle $(LIBS) -o $@
+
+