summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Ammann <philipp.ammann@posteo.de>2019-12-03 20:04:13 +0000
committerJoonas Niilola <juippis@gentoo.org>2019-12-04 16:48:34 +0200
commite36d240bda890cd75ffabc4b977d1aec00326676 (patch)
treeaa2f1a999193782cb233928dbbce71c1a2410342 /dev-libs/nsgenbind/nsgenbind-0.7.ebuild
parentdev-util/netsurf-buildsystem: bump to version 1.8 (diff)
downloadgentoo-e36d240bda890cd75ffabc4b977d1aec00326676.tar.gz
gentoo-e36d240bda890cd75ffabc4b977d1aec00326676.tar.bz2
gentoo-e36d240bda890cd75ffabc4b977d1aec00326676.zip
dev-libs/nsgenbind: bump to version 0.7
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/13232 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/nsgenbind/nsgenbind-0.7.ebuild')
-rw-r--r--dev-libs/nsgenbind/nsgenbind-0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/nsgenbind/nsgenbind-0.7.ebuild b/dev-libs/nsgenbind/nsgenbind-0.7.ebuild
new file mode 100644
index 000000000000..e85a58a5c920
--- /dev/null
+++ b/dev-libs/nsgenbind/nsgenbind-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="generate javascript to dom bindings from w3c webidl files"
+HOMEPAGE="http://www.netsurf-browser.org/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-util/netsurf-buildsystem
+ virtual/yacc"
+
+_emake() {
+ source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=binary $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+}