summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 19:05:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 19:51:42 +0100
commit1b1cccd97d88875133ef4e4c41c0a0de5c84a2c8 (patch)
tree2e2d7a890621ac480da623fff381e1deb0ac7543 /dev-libs/nsync/nsync-1.24.0.ebuild
parentmedia-fonts/terminus-font: Stabilize 4.49 ppc64, #774429 (diff)
downloadgentoo-1b1cccd97d88875133ef4e4c41c0a0de5c84a2c8.tar.gz
gentoo-1b1cccd97d88875133ef4e4c41c0a0de5c84a2c8.tar.bz2
gentoo-1b1cccd97d88875133ef4e4c41c0a0de5c84a2c8.zip
dev-libs/nsync: 1.24.0 version bump, EAPI-7 bump, cmake.eclass
Bug: https://bugs.gentoo.org/770580 Closes: https://bugs.gentoo.org/713500 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/nsync/nsync-1.24.0.ebuild')
-rw-r--r--dev-libs/nsync/nsync-1.24.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/nsync/nsync-1.24.0.ebuild b/dev-libs/nsync/nsync-1.24.0.ebuild
new file mode 100644
index 000000000000..ef961974705e
--- /dev/null
+++ b/dev-libs/nsync/nsync-1.24.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="C library that exports various synchronization primitives, such as mutexes"
+HOMEPAGE="https://github.com/google/nsync"
+SRC_URI="https://github.com/google/nsync/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DOCS=( README )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSYNC_ENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}